instrument cluster - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-28-02, 04:41 AM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Sutherland
Posts: 48
instrument cluster

my instrament cluster is playing up.
It seems that it doesn't sense that the ignition is turned.
None of the gauges come on.
When the lights are on the headlight warning lamp is lit.
slowjud is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-28-02, 04:43 AM
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
Hey mate, have you checked the fuse for the interior lighting? This may be blown or not installed properly.

Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline  
post #3 of 9 (permalink) Old 06-28-02, 04:44 AM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Sutherland
Posts: 48
can somebody help me
slowjud is offline  
post #4 of 9 (permalink) Old 06-28-02, 04:50 AM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Sutherland
Posts: 48
its not the fuse, all the fuses are ok.
slowjud is offline  
post #5 of 9 (permalink) Old 06-28-02, 04:59 AM
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
hmmm... what model is the car?

Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline  
post #6 of 9 (permalink) Old 06-28-02, 05:04 AM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Sutherland
Posts: 48
89 ea gl
slowjud is offline  
post #7 of 9 (permalink) Old 06-28-02, 04:54 PM
Registered User
 
Join Date: May 2002
Posts: 60
Have you been playing around with dash? Maybe you forgot to screw the earth wires back? Check the ones behind the drivers side footwell kick panel and the one on top of the dash under that plastic trim near the windscreen ( remove the 2 screws).
image is offline  
post #8 of 9 (permalink) Old 06-28-02, 08:17 PM
Veteran Ford Member
 
Join Date: Feb 2002
Location: Lamb on Chapel, Chapel Street.
Age: 30
Posts: 2,893
There are two plugs going in to the back of the instrument cluster. Mabye one of these could be loose?

Sundeep
Sundeep is offline  
post #9 of 9 (permalink) Old 06-30-02, 02:53 PM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Sutherland
Posts: 48
I had the car checked and there was a problem with the stop lights. I don't know what this has to do with the instrament cluster but thats what they said.
slowjud is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
XG to XF instrument cluster conversion? falconS General Tech 7 12-12-03 03:26 AM
I need a picture of an XF instrument cluster. help! falconS General Tech 15 01-12-03 07:33 PM
Monaro series 2 pics FPRXR-6 The Pub 28 12-10-02 09:43 PM
Instrument cluster conversion TRIKFAB General Tech 0 03-31-02 04:29 PM
Instrument cluster Zomwit General Tech 8 03-12-02 06:54 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome