LCD's on EB Ghia all out to lunch - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-06-2002, 17:02   #1 (permalink)
KLOMP
Guest
 
Posts: n/a
LCD's on EB Ghia all out to lunch

Today I lost all lights to all LCD displays....for the life of me I cannot suss it out any ideas?
PS everything else is great just very hard to see speedo,trip meter,climate control,doors open map..... I checked Fuses...fusable links...surely all globes could not have blown at once?....especially as all other dimable lights in dash work fine....mmmmmm
  Reply With Quote
Sponsored Links
Advertisement
 
Old 05-06-2002, 19:01   #2 (permalink)
Brent79
Guest
 
Posts: n/a
You mean the lights behind the LCD panels? not the lights that come on when you turn on yer parkers?

Brent
  Reply With Quote
Old 05-07-2002, 14:06   #3 (permalink)
89 DA LTD 3.9MPI
 
Zomwit's Avatar
 
Join Date: Jul 2001
Location: Sydney
Posts: 364
Had the same problem before but it just turned out to be a fuse.
__________________
Normality is the most common form of insanity

--ath0-- ....gone
Zomwit is offline   Reply With Quote
Old 05-07-2002, 15:21   #4 (permalink)
KLOMP
Guest
 
Posts: n/a
All lights on the dash displays work other than the ones that illuminate the LCD numbers.....I thought there may have been a power source just for LCD's but the Genuine ford manual and the circuit diagrams tell you bugger all....everything on my EB Ghia works great other than this....
Have pulled all fuses and swapped them about but nothing...I thought it may have been the dimmer on the light switch but all other lights dim ok.....have checked all fusable links...all AOK....any ideas?
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EL ghia Dash into EB ghia jmartion Interior | Electrical | ECU 4 09-14-2004 01:10
EA Fairmont Ghia to EB Fairmont Ghia Instruments... help XplodBoom General Tech 5 05-11-2003 01:31
BA Fairmont Ghia V8 review Go Auto sandmanls1 Australian Falcons 1 02-03-2003 22:45

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:51.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.