My damned EA - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-22-2003, 23:36   #1 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Shepparton, Victoria
Age: 32
Posts: 229
mad My damned EA

Well, the EA deathbug has struck again! I finally have had it with this car. I am going to sell it when it's running again.

I finally took 2 weeks holidays to rebuild the motor and fix all the little problems the EA had and it decided to extend a 3-4 day job to the whole 2 weeks! After finally getting the motor apart, my old man decided to remove the lip from the bore, and scored the block about 10 thou where the rings run cause the tool moved down! Anyway got the motor together, all good and timed properly, dropped it into the car, put on the wiring looms and manifolds etc. and went to fire it up on the 7th day of working on this car, and she wont fire! I spent the next few days tracing voltages and everything and have now given up. I have spark 10 deg BTDC. Injectors are pulsing and fuel is going in. Motor has the right amount of compression. Wont even kick! I was so pissed off! It is now at a mechanics, which I had them out to have a look and they couldnt work it out at home, so i had to tow it to his workshop.

My question is, does anyone have any ideas what could be wrong? Me, my old man and these mechanics don't know. They could only suggest weak spark, but were clueless when a new coil didn't fix it!
So again, any suggestions?
__________________
EA Fairmont Ghia : 3.9L MPFI, 2.5" cat back sports exhaust, K&N panel filter. Pioneer head unit, pioneer 4" three way fronts, Pioneer 6" 3 way rears, 2x 12" subs, blue interior light.
My main pride and joy : '76 XB Fairmont GS, 250CI, 140,000 Km and all stock.... for now! (Factory air-con on the way)
SilverEA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-22-2003, 23:52   #2 (permalink)
96 EF Futura
 
SiX_iN_a_RoW's Avatar
 
Join Date: Aug 2002
Location: Now Residing in Brisbane
Age: 31
Posts: 2,494
Re: My damned EA

are you sure you put the dizzy back in with the motor on TDC of the compression stroke?
Other than that it could be a bad TFI module or something to do with the dizzy itself ( u DID put the rotor button in didnt you?? )
if it has spark, fuel and its timed it should bloody well run!
__________________
Lets go find that Hotdog tree I planted

Lowered EF Futura
Black Steelies ( too cheap to buy proper mags )
SiX_iN_a_RoW is offline   Reply With Quote
Old 06-22-2003, 23:54   #3 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: My damned EA

Distributor put together correctly.

How much of the motor was torn down for the work done, the whole thing to bits or what was touched.

Dellboy999
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 06-23-2003, 00:01   #4 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Shepparton, Victoria
Age: 32
Posts: 229
Re: My damned EA

yes, dizzy was put in and timed on TDC. I have got another dizzy and TFI from wreckers and made no difference. Bottom end of motor didn't get touched when I got another block. Didn't even pull the sump off this one cause the bores hardly had a lip. So the head was taken off and refitted and timing chain and tensioners were out and replaced. (Yes the rotor button IS in!!!) I just dont get it. It sparks on IGN 10deg BTDC. It has fuel. So YTF doesn't it go!
__________________
EA Fairmont Ghia : 3.9L MPFI, 2.5" cat back sports exhaust, K&N panel filter. Pioneer head unit, pioneer 4" three way fronts, Pioneer 6" 3 way rears, 2x 12" subs, blue interior light.
My main pride and joy : '76 XB Fairmont GS, 250CI, 140,000 Km and all stock.... for now! (Factory air-con on the way)
SilverEA is offline   Reply With Quote
Old 06-23-2003, 00:05   #5 (permalink)
8 cylinder symphony
 
b-juggles's Avatar
 
Join Date: Mar 2002
Location: Sydney
Posts: 1,348
Re: My damned EA

This may sound totally stoopid, but do you have an immobiliser or kill switch or something? I sat around for two days trying to work out why my eb wouldnt turn over...realised it was a freaken kill switch on the underside of the console that I must have flicked on (i only had the car a month and didn know it was there)
b-juggles is offline   Reply With Quote
Old 06-23-2003, 00:15   #6 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Shepparton, Victoria
Age: 32
Posts: 229
Re: My damned EA

No, I don't have a kill switch or anything. I have a pre smartlock computer. I Just don't get why I drove it into the shed running perfectly fine (except the problems that I was going to fix!) put it all together and now she doesn't go!
__________________
EA Fairmont Ghia : 3.9L MPFI, 2.5" cat back sports exhaust, K&N panel filter. Pioneer head unit, pioneer 4" three way fronts, Pioneer 6" 3 way rears, 2x 12" subs, blue interior light.
My main pride and joy : '76 XB Fairmont GS, 250CI, 140,000 Km and all stock.... for now! (Factory air-con on the way)
SilverEA is offline   Reply With Quote
Old 06-23-2003, 00:28   #7 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: My damned EA

Enough charge from the battery, I built a TC costina motor once, was 100% sure I had everything set right, it would bloody fire, checked, double checked, 10 times checked everything. In the end grabbed the battery from another car, it fired in like 2 seconds, learnt a lesson there.

Dellboy999
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 06-23-2003, 00:40   #8 (permalink)
Registered User
 
Join Date: Dec 2002
Location: Shepparton, Victoria
Age: 32
Posts: 229
Re: My damned EA

yep, checked battery, charged it, changed it, jumped it. No difference. Can anyone see why I was getting frustrated by this stage!
__________________
EA Fairmont Ghia : 3.9L MPFI, 2.5" cat back sports exhaust, K&N panel filter. Pioneer head unit, pioneer 4" three way fronts, Pioneer 6" 3 way rears, 2x 12" subs, blue interior light.
My main pride and joy : '76 XB Fairmont GS, 250CI, 140,000 Km and all stock.... for now! (Factory air-con on the way)
SilverEA is offline   Reply With Quote
Old 06-23-2003, 00:58   #9 (permalink)
Ford Member
 
Join Date: Jun 2002
Age: 38
Posts: 162
Okay, this may sound really screwy.

Make sure you got both grounds connected to the battery.

Two leads a fat cable and a thinner one should screw onto the neg terminal.

David.
EB2Fairmont is offline   Reply With Quote
Old 06-23-2003, 02:38   #10 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: My damned EA

EB2 has a point, did you connect all earths to the block, etc, properly after connecting everything up again.

Dellboy999
Dellboy999 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA to ED Falcon review Aussie Falcon The Pub 13 08-24-2004 20:35
XD monts same as EA engine monts ?a 351 into a EA will it go ? Falcon kid General Tech 31 06-21-2004 22:58
EA in Wheels' all-time top 10 Falcons. However... Troutman Suspension | Wheels&Tires | Brakes 36 02-22-2004 02:06
Damned EA again SilverEA General Tech 7 02-04-2003 15:58
Damned EA Earths SilverEA General Tech 1 02-03-2003 12:56

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.