Need help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-11-13, 12:29 AM Thread Starter
Registered User
Join Date: Oct 2013
Posts: 1
Need help

Hi guys I have a 95 ef falcon, it's got problems. It was cutting out while driving and now it just cranks and won't fire up, it has a near new cool pack, I just replaced the crank angle sensor too, after I replaced the crank sensor it started up and ran for about 2 mins then spluttered and died again.
Has anyone got any ideas as to what could be causing the issue
Cammo_ef is offline  
Sponsored Links
post #2 of 3 (permalink) Old 10-11-13, 04:36 AM
R.S.LOGAN's Avatar
Join Date: Apr 2007
Location: Scotland
Posts: 13,656
Re: Need help

Need to try and tie the fault down a bit and check if you are getting fuel and spark first .Take it you mean coil pack ?
R.S.LOGAN is offline  
post #3 of 3 (permalink) Old 10-11-13, 09:27 PM Administrator
Big Block Ford's Avatar
Join Date: Apr 2001
Posts: 4,748
Re: Need help

Ignition module could be the problem if you are getting no spark.

71 429SCJ Mustang
Big Block Ford is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome