Need Help: Engine light on and Car stalls from 20mph-30mph as well as shifting - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-08-06, 11:41 AM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 9
Need Help: Engine light on and Car stalls from 20mph-30mph as well as shifting

Hi guys I am new to the forum and am glad to find other great ford focus enthusiasts. I drive a 2002 ford focus LX with about 60k miles,great all around car. I need your help or advice for my issue.

My cars engine light is on (on the left side of the gauge cluster) and the issue is my car seems to have a problem accelerating from 20mph to 30mph its fine after that but then the car does the same thing from 50 mph to 70 mph. The car seems to be having trouble finding gears but runs good after it reaches a steady cruising speed. I'm thinking it could be timing, transmission, or maybe computer. I do the normal maintenance (ie; oil, tires) but have yet to do a tune up. Also I was told from my brake shop (brake max) that my shock is worn in the left rear.

Your help and advice is greatly appreciated.

jay

LXFord02 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-09-06, 03:24 PM
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 33
Posts: 281
Re: Need Help: Engine light on and Car stalls from 20mph-30mph as well as shifting

needs to be scanned by a shop, computer has a code and will tell u what is wrong, most likely a speed sensor

68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline  
post #3 of 4 (permalink) Old 11-09-06, 05:41 PM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 9
Re: Need Help: Engine light on and Car stalls from 20mph-30mph as well as shifting

Another member from the forum was saying that it might be the shift solenoid. I believe he's had the same issue. Have you ever had a issue such as this.
LXFord02 is offline  
post #4 of 4 (permalink) Old 11-10-06, 01:18 PM
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 33
Posts: 281
Re: Need Help: Engine light on and Car stalls from 20mph-30mph as well as shifting

i've barely touched the focus repair wise but i've had taureses shift screwy and it was the speed sensor. u need the computer scanned, cant just shoot blind with cars nowadays.

68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome