No Heat 97 Taurus - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-08-2007, 11:05   #1 (permalink)
Registered User
 
Join Date: Mar 2007
Posts: 1
confused No Heat 97 Taurus

I have a 97 3.0 taurus and After changing the heater hoses and antifreeze I still do not have heat, The car will sometimes get a little heat but only through the vents. Please help!
sdstone is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-08-2007, 16:36   #2 (permalink)
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 31
Posts: 281
Re: No Heat 97 Taurus

most likely air locked, may have to get a flush kit that has a tee you can splice into a heater hose. sometimes running it at high rpms will move the water pump fast enough and push the air out of the heater core.
__________________
68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline   Reply With Quote
Old 03-12-2007, 21:26   #3 (permalink)
Registered User
 
Join Date: Mar 2007
Location: St Louis, Mo
Posts: 250
Re: No Heat 97 Taurus

Check the thermostat to make sure its functioning properly and also check the valve that closes off the water supply. Also check to see if your heater vents are opening like they should. Should be easy to run down. Probably a stuck thermostat if I had to guess.
Sand1 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.