No Radiator Pressure - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-15-03, 01:49 AM Thread Starter
Lab Rat
 
Join Date: Nov 2002
Location: 1500km north of Perth
Age: 56
Posts: 165
No Radiator Pressure

Just done a 400km round trip and after the motor was turned off.
I waited a minute or two then popped the bonnet and they was no pressure in the top radiator hose.
If you gave the top radiator hose a squizzes it just runs into the overflow tank.
Is this normal for the BA V8s as iam not loosing any water.


I still miss my EX
but my aim is getting better

Last edited by DavoXT; 11-15-03 at 01:51 AM.
DavoXT is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-15-03, 04:14 AM
gone
 
laminge's Avatar
 
Join Date: Feb 2001
Posts: 10,402
Re: No Radiator Pressure

Yes

Had the same thing on my XR8
laminge is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome