Oil pumps - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-25-2004, 15:47   #1 (permalink)
Wannabe mechanic :)
 
Join Date: Dec 2002
Posts: 694
Oil pumps

Is this the next epidemic to hit the early E-series? After doing X-Rated's oilpump, I've been watching my oil pressure light. Not that I have had to, a few times lately it has stayed on long enough that the audiable warning starts going (god I hate that beep).. in the last few days it has been going off after 1 second then comming back on for 2 seconds, then it stays off.. Just checked oil level this morning and it was just under half-way between add and full on the dipstick, so it's not a problem with a lack of oil (but I did top it up a little anyway)..

After how many thousand km have you replaced your oilpump on an EA-EB? At 180,000km or so, I wouldn't think it needs a new oil pump yet (unless the little pressure regulator spring is snapped??)

Thanks

Juarez
__________________
TQE, SWB, ATPS, Worst of the E-series.. and I wouldn't have it any other way
juarez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-25-2004, 17:45   #2 (permalink)
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 43
Posts: 3,838
Re: Oil pumps

How clean/new is your oil, how often do you replace it ?
__________________
I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline   Reply With Quote
Old 10-25-2004, 18:15   #3 (permalink)
Wannabe mechanic :)
 
Join Date: Dec 2002
Posts: 694
Re: Oil pumps

The oil is pretty clean (I pretty much run straight LPG), and is at most 3000km old - I replace the oil every 5,000km
__________________
TQE, SWB, ATPS, Worst of the E-series.. and I wouldn't have it any other way
juarez is offline   Reply With Quote
Old 10-25-2004, 18:17   #4 (permalink)
{';'}
 
XRated's Avatar
 
Join Date: Jan 2003
Location: A Shoe
Age: 30
Posts: 4,356
Re: Oil pumps

Not good James :sad: My light used to come on and off consistently until all the oil was pumped around It might be worth checking out very soon. Have you checked the oil pressure sender/switch?
__________________

Quote:
Originally Posted by Sundeep
Eh Yagz, suck my left teste mate I'll have boost for $1k, even if it is only 1 pound.

Check my ride, HERE
XRated is offline   Reply With Quote
Old 10-25-2004, 18:39   #5 (permalink)
nEb
HYPER-6
 
nEb's Avatar
 
Join Date: May 2003
Location: Werribee, VIC
Age: 30
Posts: 593
Re: Oil pumps

with my car i have the oil pressure guage instead of the light. when i start my car the engine ticks for a few seconds until the oil pressure goes up and then stops. when my car is sitting in one spot idling the guage is at around the 1/4 mark. and then when i am driving it goes to around halfway. pull up at lights etc the guage goes back down to around 1/4 mark. is this normal or something stuffed?
__________________
EBII WAGON 5SPEED MANUAL DRIVER
nEb is offline   Reply With Quote
Old 10-25-2004, 21:18   #6 (permalink)
Veteran Ford Member
 
Join Date: Feb 2002
Location: Lamb on Chapel, Chapel Street.
Age: 28
Posts: 2,893
Re: Oil pumps

Guess who has an oil pump?

Check the connection of the wiring to the sender unit before you start replacing oil pumps.

Sundeep
Sundeep is offline   Reply With Quote
Old 10-25-2004, 21:37   #7 (permalink)
jjj
Registered User
 
jjj's Avatar
 
Join Date: Mar 2003
Location: Qld
Posts: 278
Re: Oil pumps

Quote:
Originally Posted by nEb
with my car i have the oil pressure guage instead of the light. when i start my car the engine ticks for a few seconds until the oil pressure goes up and then stops. when my car is sitting in one spot idling the guage is at around the 1/4 mark. and then when i am driving it goes to around halfway. pull up at lights etc the guage goes back down to around 1/4 mark. is this normal or something stuffed?

That's normal mate, my car oil pressure gauge does the same thing although at start up it goes just past halfway.

cheers luke.
__________________
1997 EL Ford Fairmont.

1 Owner vehicle,
78000km's on the clock (12-1-05),
Showroom condition with all the fairmont goodies,
Metallic Silver.
jjj is offline   Reply With Quote
Old 10-25-2004, 22:21   #8 (permalink)
Wannabe mechanic :)
 
Join Date: Dec 2002
Posts: 694
Re: Oil pumps

Sunny I don't need an oilpump I'm MUCH more worried about the labour side of things than the parts side of things on this one..

We should have another mod day, and we'll rent a welding tool, and just cut all the cross-members and remove the sumps that way :) Could get about 10 cars done in a day..
__________________
TQE, SWB, ATPS, Worst of the E-series.. and I wouldn't have it any other way
juarez is offline   Reply With Quote
Old 10-26-2004, 02:09   #9 (permalink)
Veteran Ford Member
 
Join Date: Jan 2003
Location: Melbourne, Australia
Age: 29
Posts: 5,083
Re: Oil pumps

Quote:
Originally Posted by jjj
That's normal mate, my car oil pressure gauge does the same thing although at start up it goes just past halfway.

cheers luke.
No it's not normal, the pump should hold consistant pressure reguardless of the revs. Of course all 200000km/10 year old pumps will suffer from it. Mine does.
psycho chicken is offline   Reply With Quote
Old 10-26-2004, 03:16   #10 (permalink)
EB6
EB6
 
EB6's Avatar
 
Join Date: Aug 2004
Location: Willunga
Age: 28
Posts: 36
Re: Oil pumps

get the pressure checked first it may just be a dodgy sender unit. also the level of your oil has limited thing to do with pressure, you could have a full sump but because say a big end bearing is worn it wont have crap all pressure. on the guages i believe at 2000rpm it should sit just bellow 300kpa. but i would deffinantly be having it looked at as oil starvation to the heads could do major damage quickly.
__________________
cam starts to work efficently at 2500rpm wheel spin starts at 2500rpm in wet, nothing sus or anything.
EB6 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil changes between services... SteevO Australian Falcons 23 09-20-2004 02:37
Oil Change Instructions For Women! big_pete The Pub 9 08-11-2004 06:12
99 Sable , oil pressure loss PHF Ford Taurus | Mercury Sable | Ford Taurus SHO | 1986-2007 0 07-10-2004 04:09
Oil on troubled waters - the press expose LS1 V8 problems RAPTOR The Pub 69 05-22-2004 01:10
The Iraqi civilians - Where are the do gooders now? BA GT-HO The Pub 34 04-12-2003 01:10

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 16:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.