oxy sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 07-22-02, 10:46 PM Thread Starter
large member
Join Date: May 2002
Posts: 31
oxy sensor

can any one tell me if there is any traps when putting in a new oxy sensor ea ghia thanx
ferrites 1234 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 07-22-02, 11:11 PM
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
Not that I know of mate. Just screw her in, and connect the plug, done.

Bass Crazy is offline  
post #3 of 4 (permalink) Old 07-23-02, 09:51 AM
NB & NCII V8 Fairlanes
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,072
If you think you might need to remove it again put some antiseize grease on the threads but under no circumstances spray or put anything on the sensor itself (it will usually kill it). There is a special socket available to do the job that makes it easier to do but it's not needed.

Regards Blue
Aussiblue is offline  
post #4 of 4 (permalink) Old 07-23-02, 06:47 PM
E-Series Acting VP
Thanatos's Avatar
Join Date: May 2002
Location: Melbourne
Age: 34
Posts: 1,432
Be sure not to put silicon or anything similar on the thread.

The oxy sensor earths onto the manifold, so anything that prevents this will cause problems. (I speak from experience).


Thanatos is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sensor brenlam Australian Falcons 4 03-28-03 03:47 AM
Cooling Fan sensor problems '91 Tempo Mike Pfleger Ford Tempo Forum | Mercury Topaz Forum 0 08-11-02 07:08 AM
Water Sensor DansEdgli General Tech 7 07-06-02 04:23 AM
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-01 02:08 PM
Replacing Cam Position Sensor sableman General Tech 1 07-05-01 03:21 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome