oxy sensor - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-22-2002, 21:46   #1 (permalink)
large member
 
Join Date: May 2002
Posts: 31
oxy sensor

can any one tell me if there is any traps when putting in a new oxy sensor ea ghia thanx
ferrites 1234 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-22-2002, 22:11   #2 (permalink)
LET EM' RIPPP
 
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
Not that I know of mate. Just screw her in, and connect the plug, done.
__________________
CAUTION: Slippery When BOOSTING!
Bass Crazy is offline   Reply With Quote
Old 07-23-2002, 08:51   #3 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,840
If you think you might need to remove it again put some antiseize grease on the threads but under no circumstances spray or put anything on the sensor itself (it will usually kill it). There is a special socket available to do the job that makes it easier to do but it's not needed.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 07-23-2002, 17:47   #4 (permalink)
E-Series Acting VP
 
Thanatos's Avatar
 
Join Date: May 2002
Location: Melbourne
Age: 33
Posts: 1,432
Be sure not to put silicon or anything similar on the thread.

The oxy sensor earths onto the manifold, so anything that prevents this will cause problems. (I speak from experience).



Dave
__________________

Thanatos is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sensor brenlam Australian Falcons 4 03-28-2003 02:47
Cooling Fan sensor problems '91 Tempo Mike Pfleger Ford Tempo Forum | Mercury Topaz Forum 0 08-11-2002 06:08
Water Sensor DansEdgli General Tech 7 07-06-2002 03:23
Understanding Engine Management - Part 1 Dan [Sac] V6 and Hot4 Tech 0 12-11-2001 13:08
Replacing Cam Position Sensor sableman General Tech 1 07-05-2001 14:21

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:44.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.