radiator/coolant prob - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-30-06, 01:02 AM Thread Starter
Registered User
 
Join Date: Jan 2006
Posts: 8
Question radiator/coolant prob

hi guys probably a stupid question but my 5 Litre ltd,s water has turned red/brown can any one please advise as i am mechanically dumb cheers Paul.....ps from my limited knowledge i assume it may be radiator corrosion if you think so too how much am i up for?

paul219a is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-30-06, 01:17 PM
Registered User
 
tufLTD's Avatar
 
Join Date: Apr 2005
Location: Caloundra, Queensland
Age: 54
Posts: 240
Re: radiator/coolant prob

Red/brown coolant is often caused by mixing different brand coolants.
Give it a flush, then service the radiator. If the radiator is pretty old, it may be better to replace it as they're pretty cheap.
A cooling system flush, radiator service + new coolant should cost around $200.
tufLTD is offline  
post #3 of 4 (permalink) Old 02-06-06, 07:22 PM
Registered User
 
Join Date: Feb 2006
Posts: 6
Re: radiator/coolant prob

Agreed. change the coolant. You can get a flush from an oil change place for cheaper than going to a machanic. Droping the lower hose will also do the trick for much cheaper, but it will not be a complete flush. what year?
DanH is offline  
post #4 of 4 (permalink) Old 02-06-06, 09:02 PM Thread Starter
Registered User
 
Join Date: Jan 2006
Posts: 8
Re: radiator/coolant prob

Thanks for your help it is a 1996 LTD 5Ltr i have done what you advised and all seems to be ok for ..i will keep my eye on it and if it plays up again it will go into my mechanic ...thanks alot guys you are all a great help!
paul219a is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome