A real headache... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-13-2002, 11:40
Posts: n/a
A real headache...

Boyz... im about to drive my piece of crap EB off a bridge..
Im having more problems with my multi-point conversion.
It feels like the whole engine has had the guts ripped out of it.
No power accompanied with loud engine noises tops the list, not to mention the erratic idles quality and hard starting. Ive just about had enuf of this CRAP car :mad: ( So im giving her one
last chance to get it right. Its booked in tomorrow for an EFI engine diagnostics to try and locate the fault. Its really starting to cost me and im not very pleased about spending $2G on a friggen EFI conversion. Im pissed off that i didnt just get an EB2 in the first place.

Sponsored Links
post #2 of 9 (permalink) Old 03-13-2002, 14:23
EA 238
Posts: n/a
MPI Conversion

Given your earlier post about TFI module pointing too far, are you sure you put the dizzy in right? If not, that could stuff everything up a treat.
post #3 of 9 (permalink) Old 03-13-2002, 14:45
Posts: n/a
Make sure u remove the plates first and scratch out serial numbers.
post #4 of 9 (permalink) Old 03-15-2002, 11:56
Posts: n/a

Well, i had to fork out $450 for some guy to end up telling me
that one of my ignition signal wires was grounded by the guy who changed over my intake manifold.. the wire apparently tells the injectors when to fire. My injectors where firing at the ECU's default. No wonder it was idling shit gutless as hell.
Funny thing was that it would work fine after 2000rpm...
But all up this conversion has cost me dearly... $300 for the
manufold, $550 to put it on, $120 to get the auto eleccie out
and another $450 to get it dyno tuned. Also, the guy mentioned that my number 5 solenoid on my auto is faulty.
I havent picked her up yet, will fetch her this arvo... he said
she goes hard - will see... He put the car on the computer and it spat out all sorts of errors... faulty coolant temp sensor,
o2 sensor and air charge sensor... all which would have contributed to my high fuel consumption.

post #5 of 9 (permalink) Old 03-15-2002, 12:27
Join Date: May 2002
Location: Melbourne, Victoria
Age: 34
Posts: 1,675
Re: Fools...

shit mate.

i didnt realise there were so many differences in the looms? they look the same according to some of the diagrams i read, and different to some others!

its ****ed!
galapogos01 is offline  
post #6 of 9 (permalink) Old 03-15-2002, 12:34
Posts: n/a
Re: Fools...

See the main problem was that the MPFI loom in the engine bay had all the nessasary pins on the one connector but the CFI connector didnt. For the CFI, the idle speed motor and some ignition wires arent connected into the main connector so u need to do a shit load of rewiring. The guy who put my manifold on didnt even have the ISC wired into the ECU.

post #7 of 9 (permalink) Old 04-12-2002, 02:27
Posts: n/a

Hey Brent i know excatly how ya feel. I am the same i so hate this damn car .. This converstion was the worst thing i had ever done... i have same problems. Since converstion. I have done the things you told me to for getting trans working thats fine but no power hey.
really sluggish runs lie shit... wish i had not have done the change. and just spent themoney on making the engine that was in there work better ..

but to late to go backnow.... anyway... all i want to do is get this thing running to its best and then get some mods done to make it fly but i am so sick of having to pay somuch money for people to do things that i should be able to do my self.. and shit that leeps going wrong..

Right there with ya brent ..

post #8 of 9 (permalink) Old 06-02-2002, 09:15
NB & NCII V8 Fairlanes
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,068
Did you use the correct MPEFI inlet manifold gasket?

Regards Blue
Aussiblue is offline  
post #9 of 9 (permalink) Old 06-02-2002, 09:17
NB & NCII V8 Fairlanes
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,068
Most gasket kits have the CFI gasket

Regards Blue
Aussiblue is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech

Quick Reply

Register Now

In order to be able to post messages on the Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
*sigh* ah - the intelligence! Rollin The Pub 14 06-01-2003 04:17
The Real Story behind McGrath's Cricket Blow-Up!!!! KenOath The Pub 2 05-22-2003 21:07
Real performance increase from extractors +sports system? Figures please. TheBow General Tech 3 04-23-2003 16:49
Headache Jamie XR6 The Pub 0 04-01-2002 01:27
Real 0-100km/h times XR_Strider_GuY The Pub 23 02-09-2002 05:17

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome