Urgent Ea temp Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-12-03, 03:32 AM Thread Starter
Registered User
 
Join Date: Jan 2003
Location: shepparton
Posts: 13
confused Urgent Ea temp Problems

hi ya all this camsscrut l am having problems with the other haves car it's an ea 3.9 lt worked to an 4,2 lt mpi l have just done an full service on it all elect part have been replaced and added coolant this is an concern due to l live in shepparton and l would like to drive it down to melbourne and l really like to know what is going as she hasd the kids in school about 40 odd minutes from her home and one on the way and an 18 month old so if any suggs please sent an message to mickcameron@hotmail.com or call me on 0421 654 658

Attached Images
File Type: jpg ea_mmm_falcon_kit2.jpg (15.6 KB, 68 views)
camsscrut is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-12-03, 03:40 AM
Registered User
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,136
What are the symptoms? What happens?

Regards Blue
Aussiblue is offline  
post #3 of 5 (permalink) Old 02-12-03, 05:24 AM
Registered User
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,136
So overeheating after running for a while.

The one on the right is the dual acting thermostat that should be fitted. Also check for blown head gasket and blocked radiator.




Regards Blue
Aussiblue is offline  
post #4 of 5 (permalink) Old 02-12-03, 05:32 AM
Registered User
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,136
And make sure you have followed the correct procedure for topping up the coolant tank and bleeding air from the system.

Regards Blue
Aussiblue is offline  
post #5 of 5 (permalink) Old 02-12-03, 02:55 PM
Pursuit Reincarnation Dog
 
Aussie Pete's Avatar
 
Join Date: Apr 2001
Location: Melbourne VIC
Posts: 7,777
Is that first post in Swahili? Shocker!!!!

BA'1.5' Pursuit 290
Lightning Strike / Reflective Orange Stripes

'General' Dog - AP's German Shepherd and Best Mate - 02Dec1998-15Dec2003.
'Pepper' Dog - General's and My Little German Shepherd Sweetie - 1996?-02Apr2006.

'Sako' Dog - My Beautiful and Pretty German Shepherd - 2001?-23Aug2006.
Aussie Pete is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
EA Falcon problems blog General Tech 19 09-23-08 04:47 PM
EA idle problems defective General Tech 3 06-03-03 05:19 PM
HELP Steering problems in EA bEAn86 General Tech 4 04-23-03 01:54 AM
FORD HELP! EA temp TurboCelica General Tech 2 10-23-02 07:04 AM
EA overheating problems - solved Kieron General Tech 2 01-22-02 05:03 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome