Weird Engine - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-22-2002, 15:40   #1 (permalink)
Senior Events Moderator
 
AU1SIXA's Avatar
 
Join Date: Feb 2002
Age: 33
Posts: 1,710
Weird Engine

Well im pretty sure when i put my foot 3/4 the way down with power on it feels faster than when i put it down to the floor and sounds alot smoother. Also the same when power is not on. Would this be the case. I might have to time myself to sorta figure out if it is really going faster. If its is going faster at 3/4 what would be the causes has any body else experianced this.

Been noticing it latly and though i would post it here

Thanks for any help

Steven Barrett
__________________
BSR (LPG BIATCH, SPER-MIN-ATOR, PEPPER BIATCH)
TEAM GALAXY(Co-Founder)
FF EVENTS ORGANISER
AUPS
AU1SIXA is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-22-2002, 22:46   #2 (permalink)
Australian Falcon Member
 
Join Date: Jun 2001
Location: Western Australia
Posts: 865
My car was like that too for a long time - lot better acceleration when throttle was fed in rather than just planted. I came across a few other people with the same thing too.

Unfortunately I can't offer a sensible solution as mine only sorted itself out when I fitted the EFXR6 head and cam - and even now it's probably marginally better if the throttle is fed in, but it's not quite as big a difference to flooring as it used to be.
__________________
IT'LL GO OR IT'LL BLOW!!!
EDFUTURA is offline   Reply With Quote
Old 05-22-2002, 23:24   #3 (permalink)
KING of KEBABS
 
XR8beast's Avatar
 
Join Date: Aug 2001
Location: Sydney
Posts: 64
Weird engine

have u tried cleaning the 2 oxygen sensors "CAREFULLY" with some metho and a cotton bud on M.A.F sensor ??? this can make a big difference believe it or not !!.
XR8beast is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Holdens new V6 EED-250 The Pub 52 08-09-2003 22:07
Ford Introduces New Duratec Sci Engine With Unique ‘smart Charge Injection’ RPO83 Ford Worldwide News 0 05-14-2003 10:59
Ford Motor Company’s 100-millionth V-8 Engine RPO83 Ford Worldwide News 3 04-29-2003 07:33
A New Boss Born in Australia RPO83 Ford Worldwide News 0 10-16-2002 18:12
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-2002 07:27

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:32.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.