What have I got? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-13-2002, 17:45   #1 (permalink)
Well Paid, Trained Monkey
 
oz_orion's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 35
Posts: 123
What have I got?

Hey, I'm in need of some help...

I've just purchased an EA Falcon and finally upgraded from my old XE and I'm having trouble working out exactly which model I have.

I've spent the whole day fixing up all the damage on the car (the previous owner was not a car lover) but I'm not a mechanical expert, I'm just good at finding replacement parts.

I know the car is a Falcon S, how do I tell if it is the EA or the EA II and how do I know if the engine is the Multi-Point fuel injected model?

I'd appreciate any help you could give me on working this out.

James
__________________
2000 AUII LTD
Madness takes its toll... please have exact change.
oz_orion is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-13-2002, 17:49   #2 (permalink)
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
EA II has body coloured B pillar on the front and rear doors, series I is black. MPI should have 3.9 MPI badges on the side, but otherwise look for the EEC-4 intake box on the front left side of the engine bay.
__________________
Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline   Reply With Quote
Old 03-13-2002, 17:55   #3 (permalink)
Well Paid, Trained Monkey
 
oz_orion's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 35
Posts: 123
Thanks for that, seems to have cleared up my lack of knowledge. The pillars are black, and there are no badges on either side of the car. The only thing on the left hand side of the engine bay is a water tank, I'm assuming for the radiator.
__________________
2000 AUII LTD
Madness takes its toll... please have exact change.
oz_orion is offline   Reply With Quote
Old 03-13-2002, 18:02   #4 (permalink)
mickt
Guest
 
Posts: n/a
Yep, try right hand side looking into the engine bay
  Reply With Quote
Old 03-13-2002, 18:17   #5 (permalink)
LET EM' RIPPP
 
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
EAI was a 3 speed. EAII was a 4 speed auto.

MPI has an air box and 6 injectors, CFI has the traditional air filter mounted onto the inlet manifold and one injector.
__________________
CAUTION: Slippery When BOOSTING!
Bass Crazy is offline   Reply With Quote
Old 03-13-2002, 18:18   #6 (permalink)
Well Paid, Trained Monkey
 
oz_orion's Avatar
 
Join Date: May 2002
Location: Sydney
Age: 35
Posts: 123
The only thing I can see on that side at the front is a small disc shaped box labeled "Tipo AT90E Electric Assisting" with three large tubes coming out of it. Mean anything to you?
__________________
2000 AUII LTD
Madness takes its toll... please have exact change.
oz_orion is offline   Reply With Quote
Old 03-13-2002, 18:22   #7 (permalink)
LET EM' RIPPP
 
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
MPI Engine.
www.ford.i8.com/images/engine_small.jpg
__________________
CAUTION: Slippery When BOOSTING!
Bass Crazy is offline   Reply With Quote
Old 03-13-2002, 21:25   #8 (permalink)
Martin
Guest
 
Posts: n/a
.

Bass, the CFI has 2 injectors, not one.
  Reply With Quote
Old 03-13-2002, 21:38   #9 (permalink)
Qld Rep 4 E Series Club.
 
Join Date: May 2002
Location: Brisbane
Age: 34
Posts: 643
Yep

There is always one!! LOL
__________________
QLD REP 4 E Series Club

Proud TQE Operator
lukeyn039 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 16:37.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.