XE Fuel pump probs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-04-03, 08:35 AM Thread Starter
Holden Member
Join Date: Apr 2003
Location: Sydney
Posts: 52
XE Fuel pump probs

Hi guys I need your help again with my bros XE...
In case some of you dont remember his XE EFI 6 developed a miss and was just plane running like crap..
Anyway he took it to a machanic and was told the fuel pump was on its way out and the injecters were stuffed.(not sure what this would have to do with the miss) but when he got it back the miss was gone...but he couldent get up to speed fast without the car stalling and he was lucky to get it going over 70km/h.
So I got a electric fuel pump off a mate from a old XF EFI 6 but the EX one is inside the tank (as some of you would know) and the EX pump is mounted outside the tank.
So what I did was took the EX pump out and replaced it with some fuel line going all the way down to the bowl like yellow thing the electric pump would site in..
Then I mounted the XF pump in the boot just neer where the fuel hose's go in the tank.
Now the stuped thing won't start!,we pulled the fuel line off where it goes to the injecter rail and turned it over and it apperes to be planty of fuel pumping so im thinking it could be no spark some how.

Anyway what I really want to know is have I gone the right way about mounting this fuel pump??
Opinons,advice please

Sorry for the long post,I just want to make it clear for you :)


VN 5 litre
VP Senator kit (One day I might get it on:p)

VK Commodore

Chris5ltr is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
No juice @ fuel Pump. 93' Probe GT MikeP General Tech 2 06-13-03 02:39 AM
Fuel pump noisey - 1997 EL wagon FordPrefect General Tech 3 12-23-02 04:29 AM
Carb motor-EFI fuel pump uteman General Tech 14 10-18-02 05:26 PM
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-02 08:27 AM
Ford Product-Led Transformation: 2003 RPO83 Trans | Driveline 0 07-22-02 07:48 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome