Blown Light Globes - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Superchargers | Turbos | N2O
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-26-2002, 21:57   #1 (permalink)
211
Registered User
 
Join Date: Sep 2001
Location: Melbourne, Vic
Posts: 593
Question Blown Light Globes

I'm having trouble with globes blowing in my XF's - in the sedan the brake lights keep blowing, (one at a time) and in the ute the spotties burn out. I get about a week's worth of use out of them. Any suggestions why? The wiring seems OK. I'm not using el cheapo globes either - well, the sedan brake lights get the Narva ones and the ute gets those stupid blue things that cost about $35 each. The original globes in the cars lasted what seemed like 10 years - as soon as I started to change them I've gone through heaps in 3 months ..... have I damaged something maybe?
__________________
Foxtrot Oscar Romeo Delta X-ray Foxtrot
211 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-26-2002, 22:52   #2 (permalink)
Registered User
 
Join Date: Dec 2001
Posts: 698
The only thing I can think of is either your Voltage in the Car is creeping up too high, (Voltage regulator ????).

Do the lights become very bright when you excelerate, and become dim at idle ???

If this is not the case, then it would have something to do with either shock and Vibration, or Temperature (Doubtful, as its now getting closer to winter).

The inly other thing I can suggests is some of those Blue H4/H1/H3 Light Bulbs are a little bodgy, in terms of the Filament connection. I had my first pair of Blue ones Blow on me within the first month (Not happy Jan !), and a Friend had the same thing after 1 week. (P.S. I am talking about the Autotechnica ones here).

I am running Narva Blue Bulbs at the moment, with that extra Xenon stuff, and hadnt had any problems with em, but by the same token, I am not really impressed with them either ?

Hope this helps
Cheers
Matti
Xyphoid is offline   Reply With Quote
Old 05-26-2002, 23:33   #3 (permalink)
Shh i'm huntin more power
 
Jase_ELXR8's Avatar
 
Join Date: Jul 2001
Location: Melbourne
Posts: 1,764
Quote:
Originally posted by Xyphoid
The inly other thing I can suggests is some of those Blue H4/H1/H3 Light Bulbs are a little bodgy, in terms of the Filament connection. I had my first pair of Blue ones Blow on me within the first month (Not happy Jan !), and a Friend had the same thing after 1 week. (P.S. I am talking about the Autotechnica ones here).

I am running Narva Blue Bulbs at the moment, with that extra Xenon stuff, and hadnt had any problems with em, but by the same token, I am not really impressed with them either ?

Hope this helps
Cheers
Matti
Blue headlight globes are S**T!!! You're better off with standard globes over them.
Jase_ELXR8 is offline   Reply With Quote
Old 05-26-2002, 23:46   #4 (permalink)
My name is Forrest....
 
Jesmol's Avatar
 
Join Date: Dec 2001
Location: Adelaide
Posts: 465
Could be you're touching the globes as you put them in, it'll do that everytime.....
__________________
Run Forrest , Run.......
Jesmol is offline   Reply With Quote
Old 05-27-2002, 02:06   #5 (permalink)
Registered User
 
Join Date: Apr 2002
Location: Sydney
Posts: 39
I was told that the blue globes were illegal unless the car came standard with them....
Does any1 know if this is true????
Kwigibo is offline   Reply With Quote
Old 05-27-2002, 05:00   #6 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,862
Condensation in the headlight module?
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Superchargers | Turbos | N2O



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yellow Light: Go or no go? thecause17 The Pub 68 05-20-2004 17:28
Changing EL Fairmont tail light globes sasscat General Tech 2 03-02-2003 13:37
Changing tail light globes on an EF XWJG34 General Tech 3 04-09-2002 03:02
Speed and Red light cameras Falchoon The Pub 4 01-18-2002 00:14
Red light camera research shows they don't work EA S The Pub 3 12-03-2001 22:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:16.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.