07 MKZ Driver side Heated/Cooled Seat - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-10-13, 06:40 AM Thread Starter
Registered User
 
Join Date: May 2013
Posts: 1
07 MKZ Driver side Heated/Cooled Seat

I have an 07 MKZ, and the problem just started yesterday. The passenger side seat works fine i will turn on the heat or the cool seat function the lights come on and I can heat the blower running great. All of sudden my driver side does not. When I start the car the driver side heated or cooled light will come on one time, after i press the button to turn it back on it will not ever light back up nor will the blower kick on. Also if I just leave it on it will kick off automatically after about 5 min and the blower runs really weak as if you had the setting on just one light when I have all three lit. Any Ideas? I have checked the fuses and they seem OK. It is just weird to me that the passenger side works fine but the driver does not.

Any help would be great, Been hitting my head against the wall

Henningfeld is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-10-13, 06:54 PM
Dazed and Confused
 
CatSkinner's Avatar
 
Join Date: May 2012
Location: Upstate New York
Posts: 5,902
Re: 07 MKZ Driver side Heated/Cooled Seat

Sounds like the EATC (electronic automatic temperature control) module is acting up. Not sure of the location, but if you can swap sides for the passenger and drivers side, you can confirm module or sensor.

Ever notice that there's so many high performance parts available for GM products?

Did you ever think that maybe they NEED them?
CatSkinner is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome