1993 Ford Escort No Turn Signals - Need Help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-30-05, 07:46 AM Thread Starter
Registered User
 
Join Date: Jan 2005
Posts: 1
1993 Ford Escort No Turn Signals - Need Help

I had a question regarding the turn signals on a 1993 Ford Escort (wagon). The turns signals quit working. Nothing lights up on the instrument cluster or the signals in front or back. The hazard lights do work so I know the bulbs arent burnt out. Any ideas how to fix this??? I cant find any fuse(s) for the turn signals.

THANKS!!!

RyanbabZ71 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-30-05, 08:05 AM
Registered User
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,143
Re: 1993 Ford Escort No Turn Signals - Need Help

Try a new flasher can (turn signal hazard lightcombination unit).

Regards Blue
Aussiblue is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AUS: 1901 Ford Sweepstakes - Sydney motor Show RPO83 Ford Worldwide News 0 10-15-03 05:57 PM
Winterbottom's winning streak ends FPRXR-6 Ford Racing Across the Globe 13 08-12-03 02:13 AM
2005 Ford Gt: An American Supercar Is Reborn RPO83 Ford GT40 | Ford GT 8 06-14-03 06:44 AM
Speech: Edsel B. Ford Ii At Automotive Press Association Luncheon In Detroit RPO83 Ford Worldwide News 0 06-06-03 01:12 AM
Women Influence Ford's History And Evolution RPO83 Ford Worldwide News 0 06-04-03 09:01 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome