65 galaxie tailight /indicator problem.... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-31-07, 03:24 PM Thread Starter
Registered User
 
Join Date: Mar 2007
Posts: 2
Exclamation 65 galaxie tailight /indicator problem....

Hi,
I have a 1965 galaxie 2 door with a 390 and three speed.
My problem is the the tailights and some of the dash lights come on when I turn the key to the run or acc postion. The indicators work okay except that the rear ones flash both sides. One is dimmer that the other through. If I turn the headlights on the indicators stop flashing and stay on. The front indicators work fine except for when the headlights are on.

I have checked fuses and all the bulbs etc. Any help would be awesome

Thanks

SLIDING is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-01-07, 03:04 AM Thread Starter
Registered User
 
Join Date: Mar 2007
Posts: 2
Re: 65 galaxie tailight /indicator problem....

bump
SLIDING is offline  
post #3 of 3 (permalink) Old 04-01-07, 05:34 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 65 galaxie tailight /indicator problem....

A car of this age is usually going to have some issues. Check all grounds you can find. Pull out all bulbs and check for corrosion in the socket. And where the wires plug in, like on your head lights, check for corrosion on those as well. Check wires for chaffing that feed your lights.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome