86 F150 has no fire - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-01-07, 09:10 PM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 5
86 F150 has no fire

I Have A 1986 F-i50 With A 5.0l And I Already Replaced Coil, Fuel Relays, And Ec Relay It Runs And Stops When It Feels Like And Then Get No Fire Replaced Fuel Filters As I Thought The Fuel Pump Was Heating Up And Blowing Relays

ford_boy 79 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-02-07, 04:34 AM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 86 F150 has no fire

Based on your very limited info, I would suggest ignition module.
thefonz is offline  
post #3 of 3 (permalink) Old 10-02-07, 06:39 AM Thread Starter
Registered User
 
Join Date: Oct 2007
Posts: 5
Re: 86 F150 has no fire

thanks i'll try that
ford_boy 79 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome