91 Escort GT rear defogger - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-25-2004, 11:04   #1 (permalink)
Registered User
 
Join Date: Mar 2003
Location: Milwaukee, WI
Posts: 131
91 Escort GT rear defogger

Hi, my rear defogger recently stopped working. The switch is such that it lays flat on the dash and I push it down towards the ground until it engages, and do the same to disengage it. When it's on a light in the switch indicates that it is turned on. When I push the switch now the light flashes for a second and then goes off. The window stays fogged up and it isn't working. I can tell that the switch works enough that there are 2 positions... one that is slightly more depressed and the off position which is less depressed. If I manually hold the switch all the way down, and push it in towards the engine compartment a little bit, the light will stay on, and the rear window defogs, so it is working. As soon as I remove my finger it turns off again. I already checked the 20 amp fuse and it is fine.

Any ideas?

Thanks,
Steve
KingKurt is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-27-2004, 20:48   #2 (permalink)
Origi-Bulge (tm)
 
Klawsterfobik's Avatar
 
Join Date: Apr 2003
Location: Geelong
Age: 29
Posts: 778
Re: 91 Escort GT rear defogger

Quote:
Originally Posted by KingKurt
If I manually hold the switch all the way down, and push it in towards the engine compartment a little bit, the light will stay on, and the rear window defogs, so it is working. As soon as I remove my finger it turns off again.
That sounds to me like a dirty contact. Pull the switch apart and check the contacts, or if you just cbf'd replace the switch.
__________________
- Dale
Supremo Grandpa Car Owner

Cows would live a lot longer if they weren't made out of steak and leather
Klawsterfobik is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
UAE: GT Showcased At Middle East Auto Show RPO83 Ford Worldwide News 0 12-09-2003 17:23
91 Escort GT Fuel Line Fusible Link sirsabre Ford Escort | Ford Laser | Ford TX3 | Ford Sierra | Mercury Capri 0 06-15-2003 12:03
GT review BOF FPV & Tickford Forum 61 04-27-2003 23:08
Arrrrghhhhh! laminge The Pub 79 04-11-2003 01:17
A Visual Link RPO83 FPV & Tickford Forum 0 01-24-2003 00:52

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 20:27.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.