92 Escort wiper issues. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-01-12, 11:42 AM Thread Starter
Registered User
Join Date: May 2012
Posts: 2
confused 92 Escort wiper issues. *Please Help ASAP*

My windshield wipers quit working the other day on my 92 Escort gt.
The fuses are fine in the fuse box, and the wiper motor has been checked and is ok.
Is there a inline fuse or switch under the hood?

at first the delay wipers started acting up and not working...then later that day all wiper speeds failed to work.
How common is it for the swtch to go?

My Escort is the 1.8ltr dohc 5speed 2door hatch.
bobsure1 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 05-04-12, 06:03 AM
R.S.LOGAN's Avatar
Join Date: Apr 2007
Location: Scotland
Posts: 13,640
Re: 92 Escort wiper issues.

Certainly not uncommon for switch / stalk to fail . Check there is power at motor first .
R.S.LOGAN is offline  
post #3 of 3 (permalink) Old 05-08-12, 05:52 AM
87_Crown_Vic's Avatar
Join Date: Apr 2009
Location: Omaha, NE
Age: 35
Posts: 374
Re: 92 Escort wiper issues.

typical issue... my fiance's 1990 Grand Marquis acted up... the delayed wiper speeds worked when you put a lil pressure on switch like you had turn signal on... and would only spray fluid if you pulled back on switch a lil bit... never fixed it since we sold the car instead by her choice

my 1986 Grand Marquis LS... Rose...
87_Crown_Vic is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome