ABS warning light and buzzing noise - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-14-2003, 21:32   #1 (permalink)
tx5 turbo
Guest
 
Posts: n/a
ABS warning light and buzzing noise

hey this is my first post and looking through others im not sure any other members have a telstar (probably cos it's missing 4 cylinders)

Car Specs : AT(1988) Telstar Tx5 Turbo Automatic. turbo timer 2.5" exhaust turbo back, the rest Stock Standard

Any way here's the problem i was installing a stereo and drained the battery by running it too much . It Wasn't fully dead but the abs light was flashing, about 7 times when i pulled the key out ( car was still running due to turbo timer). So i charged the battey fully and now the ABS light doesnt flash it just coms on once and there is a pretty loud buzzing noise form the engine bay (around where the ignition coil and charcoal cannister is). Also the operation of window wipers and electric windows are really slow like the power is still low and the interior lights are really dim, but battery is fine.

Any help would be appreciated and hopefully i will be able to enjoy participating in these forums
  Reply With Quote
Sponsored Links
Advertisement
 
Old 07-24-2005, 18:50   #2 (permalink)
Registered User
 
Join Date: Jul 2005
Posts: 1
Re: ABS warning light and buzzing noise

hi i also have a tx5 turbo 90 model and i have the abs warning light coming on. It flashes 6 times when i start the car and 1 then pause the 6 times when i turn it off and the turbo timer takes over, just like to know if you found an answer to your problem and if you still own the car.
chrisal25 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:23.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.