All lights/elec.sys died when starting engine - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-30-04, 08:37 PM Thread Starter
Registered User
Join Date: Oct 2004
Posts: 1
All lights/elec.sys died when starting engine

I never experienced electrical problems with this 1999 Taurus Wagon w/ 3.0 Duratec before. Today after about 30 min stoppage I tried to start engine. All lights (cabin, dashboard) died when I turned the key to "starter" position. A strange boiling(?) or zooming noise appeared -- seemingly from a small black box attached to the right side of the battery. In a minute or so the noise disappeared and cabin light appeared again. With the key in "Accessory" position, radio worked. When I re-tried to crank the engine, electrical system died again (re-vived in ~ 2 min when the same strange noise ceased). Electrical system would also die on turning the low beam light on. After about 2 hours, the only sign of life in the car is the "Theft" indicator normally blinking; all other systems are dead (cabin light, remote opener, braking lights, etc.). What could it be?

Another observation (not sure if related at all): about 3 days ago when I started the engine, the "Theft" indicator started rapidly flashing; I stopped and re-started; the problem never disappeared.
yfradkin is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil on troubled waters - the press expose LS1 V8 problems RAPTOR The Pub 69 05-22-04 02:10 AM
Holdens new V6 EED-250 The Pub 52 08-09-03 11:07 PM
Done by Hand: Mazda's new Renesis engine receives surprisingly lowtech final assembly Stacy94PGT Mazda Forum 0 02-24-03 08:35 AM
Product Preview:RX-8 sports car uses Wankel engine to become wild on wheels Stacy94PGT Suspension | Wheels&Tires | Brakes 2 02-06-03 09:02 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome