battery light - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-22-2002, 04:44   #1 (permalink)
Registered User
 
Join Date: Jul 2002
Location: melb
Posts: 53
Question battery light

battery light constanly on ,car wont idle without acceleration on startup ,after about 30sec will idle norm is this common with alternator about to go or gone
eager is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-22-2002, 04:59   #2 (permalink)
Birth, Drift, Death...
 
Rollin's Avatar
 
Join Date: Jun 2002
Location: Drifting Brisbane...
Age: 32
Posts: 3,039
what sort of car?
__________________
Slick, Quick and Fulliii SIK!!!
Proud TQE Operator

197.4hp at the wheels, 14.505@152.46km/h
Tuning in progress...
*CLICK TO SEE MY XR6*
I can get new Genuine Holden/Ford/Audi/Land Rover/Honda parts cheap, PM me!
Rollin is offline   Reply With Quote
Old 07-22-2002, 05:30   #3 (permalink)
Registered User
 
Join Date: Jul 2002
Location: melb
Posts: 53
ea ghia
eager is offline   Reply With Quote
Old 07-22-2002, 17:42   #4 (permalink)
Registered User
 
Kenaz's Avatar
 
Join Date: Mar 2002
Location: Melbourne
Age: 32
Posts: 2,061
Definately sounds like the alternator. I was cruising along one day when the battery light came on. I parked the car in the garage for the night, went to start in the morning and nothing. Battery and alternator were both dead.
Kenaz is offline   Reply With Quote
Old 07-23-2002, 03:34   #5 (permalink)
Registered User
 
Join Date: Jul 2002
Location: melb
Posts: 53
got s/h alt today, got mrs to pick it up turns out its wrong pulley cant get either off, driving me mad
eager is offline   Reply With Quote
Old 07-23-2002, 08:36   #6 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,840
Try swapping the regulators if they fit and you still have the old alternator; the failed regulator is the usual cause of the red light syndrome.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 07-23-2002, 09:37   #7 (permalink)
I Love Forced Induction.
 
BLWNEB's Avatar
 
Join Date: Dec 2002
Posts: 569
sounds like you might have a faulty alternator, most likely be the reg, but get it checked out take it to an auto elec so they can check the charge rate and so on.
__________________
IF YOU DONT TRY IT YOU WONT KNOW.
BLWNEB is offline   Reply With Quote
Old 07-24-2002, 03:23   #8 (permalink)
Registered User
 
Join Date: Jul 2002
Location: melb
Posts: 53
changed alt but still wont idle properly or start properly redlights gone
eager is offline   Reply With Quote
Old 07-29-2002, 06:16   #9 (permalink)
Birth, Drift, Death...
 
Rollin's Avatar
 
Join Date: Jun 2002
Location: Drifting Brisbane...
Age: 32
Posts: 3,039
check all of the earth points for good contact and bolt tension, also check battery terminals, beyond that i have NFI
__________________
Slick, Quick and Fulliii SIK!!!
Proud TQE Operator

197.4hp at the wheels, 14.505@152.46km/h
Tuning in progress...
*CLICK TO SEE MY XR6*
I can get new Genuine Holden/Ford/Audi/Land Rover/Honda parts cheap, PM me!
Rollin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yellow Light: Go or no go? thecause17 The Pub 68 05-20-2004 17:28
Dual battery setup complete! (PICS) The Goodz Interior | Electrical | ECU 29 10-09-2003 01:06
EA battery Light Chad_XF Interior | Electrical | ECU 8 09-05-2002 09:23
Service Engine Light cejonman44 Ford Mustang Forum 1 01-31-2002 13:25
Speed and Red light cameras Falchoon The Pub 4 01-18-2002 00:14

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:51.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.