Big Problem!!! 88 F-150 not starting!!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-29-2007, 17:39   #1 (permalink)
Registered User
 
Join Date: Jun 2007
Posts: 1
confused Big Problem!!! 88 F-150 not starting!!!

this is one of those classic "my car won't start" threads.

so anyway my truck has been giving me a lot of problems over the past few months. first the starter was bad, replaced that. the battery died on me, replaced that. starter solenoid went bad, replaced that. after the last fix my truck was running fine. but one day i went to work and went i got in to go home it didn't start.

replaced the battery again and still didn't start. but it does have the click click sound. it sounds like it's coming from the starter solenoid. i'm stuck because that was brand new also. haven't replaced it yet, but even if that fixes it would could be the ultimate problem of the truck.

this info might help: since the problems starting happening my radio would reset itself sometimes on startup. kinda like if i disconnected the battery. checked my battery and everything is tight.

was also told it could be my grounds.

i'm lost can someone help me out.

thanks

frankie
paleo699 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-29-2007, 18:44   #2 (permalink)
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,708
Re: Big Problem!!! 88 F-150 not starting!!!

Check all connections,pos. and neg. battery to solenoid(relay) to starter. They must be clean and tght. Also check to be sure the wires are not corroded under the insulation.
thefonz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 17:54.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.