Dead battery - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-26-05, 06:40 PM Thread Starter
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Dead battery

E series wagon just spat another new battery , 2nd in 3 months , everything electrical is fine but jump in turn the key and pretty much dead , guess a warranty claim again on Monday now the question is anyone else experienced this sort of thing , new starter rebuilt altenator (120 amp) and simply has me shaking the head . ( our other e wagon NEVER misses a beat)

atec77 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-27-05, 10:10 PM Thread Starter
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Re: Dead battery

Quote:
Originally Posted by atec77
E series wagon just spat another new battery , 2nd in 3 months , everything electrical is fine but jump in turn the key and pretty much dead , guess a warranty claim again on Monday now the question is anyone else experienced this sort of thing , new starter rebuilt altenator (120 amp) and simply has me shaking the head . ( our other e wagon NEVER misses a beat)
Finally fell over it last night . glove box door was not seating tight , so it would shake a little loose , loght comes on and draws an amp , flat in a short time , pull bulb and all is well.
atec77 is offline  
post #3 of 3 (permalink) Old 12-01-05, 02:07 AM Thread Starter
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Re: Dead battery

Quote:
Originally Posted by atec77
Finally fell over it last night . glove box door was not seating tight , so it would shake a little loose , loght comes on and draws an amp , flat in a short time , pull bulb and all is well.
Still been having a few problems with slow cranking hot . ended up cleaning the earth connection to the body and adding a new 12 mm earth strap from the motor on the exhaust lifting bracket to the battery earth , a completly different car that spin like a beaty and starts everytime on the 3rd turn.. earthing on this car was crap :)
atec77 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome