EA Alternator Troubles - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-23-2005, 01:11   #1 (permalink)
Registered User
 
89Falcon's Avatar
 
Join Date: Sep 2004
Location: New Zealand
Age: 26
Posts: 48
confused EA Alternator Troubles

The alternator on my EA is really pissing me off
its an 85 Amp model
and it stopped charging not all of a sudden
the light used to come on and a tap from a hammer on the side of the alternator usually fixed it
we took the regulator/brush assy. out and checked the brushes they werent overly worn but slightly sticky so we freed them up and put them back in but the alternator light wouldn't go off. same thing happened when we lengthened the brushes im thinking it is the regulator but also hoping it isnt because of $$$
so is there anything that commonly f**ks out on these alternators
cheers
Dan
__________________
Previous Rides:
1989 EA Falcon GL 4.0 LPG 5spd (ex 3spd auto)
1990 EA Fairmont Ghia 3.9 MPI 4spd Auto
1989 EA Falcon S 3.9 MPI 5spd

Current Rides
1989 EA Falcon S 3.9 MPI 5 spd
1990 EA Fairmont Ghia 3.9 MPI No Speed (soon to be manual)

And Still not sick of them yet
Havnt Blown a head gasket yet either
89Falcon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-23-2005, 05:38   #2 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,880
Re: EA Alternator Troubles

New regulator and/or wire from alternator to battery.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:34.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.