EA Problem - battery/alternator - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-20-03, 01:52 AM Thread Starter
true blue thru & thru
big_pete's Avatar
Join Date: Aug 2001
Location: Photo-Choppin'
Age: 31
Posts: 1,387
EA Problem - battery/alternator

my mums car has officially shat itself!

the problem has been occuring for awile now,

the battery seems to be getting flattened the more the car is driven & i have been forced to change (then recharge) the battery every 3-4 days.

the battery was practically brand new, so i know its not the battery,

i was wondering if the problem could be the alternator or wiring,

i need help to diognose the problem, cause mum was going to take the car to a mechanic, but because of low funds doesnt know if this will be possible.

any ideas???

big_pete is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-03, 02:04 AM
Two SC 61's = trouble
ebxr8240's Avatar
Join Date: Jul 2001
Location: Penrith,nswAus/Morrinville.NZ
Age: 62
Posts: 6,360
Let car idle at say 1000 rpm then pull battery cable off, if it stops the alt is stuffed. Then take off alt and go to get an exchange one. Or first ring around the wreckers. Iff you have a voltmeter it should read atleast 13v across battery iff it drops bellow 12v when you turn lights on alt stuffed. Check all conections as well...

Don't be afraid to try something new. Remember, amateurs built the Ark...Professionals built the Titanic!
Tuned & maintained by "Peppertree Perfmormance". Dart block, Scat 4340 steel crank, Custom C.P pistons.Oliver rods.. Mal Wood twin plate clutch.. Twin SC61/2's,482 rwkw/ 645 rwhp..
Passengers, myocardial infarction material..
R.I.P Possum...
ebxr8240 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
EA - Heater Problem galapogos01 Interior | Electrical | ECU 5 08-04-04 09:28 PM
EA CFI 3sp auto (1989): Problem with idle return sambulance Inline 6 Tech 4 08-09-03 05:06 AM
EA firing problem Skara Trinsik General Tech 1 04-01-03 05:51 PM
Ea II shuddering problem davocol General Tech 1 02-10-03 12:39 AM
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-02 10:39 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome