ea speedo problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-11-05, 02:37 AM Thread Starter
Registered User
 
Join Date: Apr 2005
Posts: 2
ea speedo problem

Hi, I need help with speedo not working in '89 ea I was given this car by a friend (after the X got the good car). Anyway I,ve tried another speedo drive as well as inst. cluster that I know works, but didn't fix the problem. perhaps someone might have a wiring diagram or could tell me where wires run.

Regards OzRS

OzRS is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-14-05, 11:38 PM
Registered User
 
Join Date: Feb 2005
Location: Perth
Posts: 113
Re: ea speedo problem

does everything else on the cluster work mate?

4/89 EA, YE OLE FAITHFUL 3 SPEED, 3.9 CFI
Currently..... costing lots of money to refuel
NARCEA is offline  
post #3 of 4 (permalink) Old 04-15-05, 05:02 AM Thread Starter
Registered User
 
Join Date: Apr 2005
Posts: 2
Re: ea speedo problem

Thanks NARCEA,
Everything else on cluster works. Not sure if the wiring runs thru ECU ?
OzRS is offline  
post #4 of 4 (permalink) Old 04-16-05, 08:05 AM
Registered User
 
Join Date: Feb 2005
Location: Perth
Posts: 113
Re: ea speedo problem

dont think it does. maybe you've been unlucky to get two speedo drives that didnt work. my speedo used to stick on zero a hell of a lot when i bought the car but a good clean up of the plug to the cluster seemed to fix that problem. i cant help you with the wiring, however i could help you put in an spak dash! maybe visit someone who does instrument cluster repairs or an autoelectrician. have a good one anyway mate

4/89 EA, YE OLE FAITHFUL 3 SPEED, 3.9 CFI
Currently..... costing lots of money to refuel
NARCEA is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome