ED XR6 lights no go - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-22-03, 01:21 AM Thread Starter
Registered User
 
Join Date: Dec 2001
Location: Sydney
Posts: 674
ED XR6 lights no go

EDXR6 falcon lights dramas
ok hears the deal,parkers F/R work in in 1st switch postion ,next postion parkers on F/R still on, but no low beam.
High beam all lights work .(all four lights)high/lowbeam and parkers
all globes are ok (100w),terminals ok,fuses ok

I thinking switch contactors,anyone had the same dramas

Im freaking out here

help me out

Thanks


Its just me in the Wagon
XR6 VCT UTE is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-22-03, 02:24 AM
Busdriver
Guest
 
Posts: n/a
Sounds like the headlight switch. Try to get one from the wreckers. New I think are pretty expensive.
 
post #3 of 6 (permalink) Old 01-23-03, 12:11 AM Thread Starter
Registered User
 
Join Date: Dec 2001
Location: Sydney
Posts: 674
It was the low beam relay next to the battery,$9 away she went

There was a burnt moth stuck in the terminals.

Its just me in the Wagon
XR6 VCT UTE is offline  
post #4 of 6 (permalink) Old 01-23-03, 03:02 AM
Black 200kw wheel barrow
 
FalKeen's Avatar
 
Join Date: Aug 2002
Location: AWC - Taren Point, Sydney
Age: 33
Posts: 3,626
in relation to your sig under your post - it obviously wasnt the moths day!

FalKeen is offline  
post #5 of 6 (permalink) Old 01-23-03, 05:46 AM
Busdriver
Guest
 
Posts: n/a
Quote:
Originally posted by edxr6wgn
It was the low beam relay next to the battery,$9 away she went

There was a burnt moth stuck in the terminals.
I am wondering how they worked when you had the high beams switched on as they should still use the same relay ???
 
post #6 of 6 (permalink) Old 01-23-03, 11:44 AM Thread Starter
Registered User
 
Join Date: Dec 2001
Location: Sydney
Posts: 674
I cant really work it out myself but looking at the schematic it makes a bit of sense how it could operate.

not a sparky

Its just me in the Wagon
XR6 VCT UTE is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ED Vs. EB XR6 Supa R00 Drag Racing Technique 28 10-07-03 04:56 AM
ED XR6 vs EBII XR6 chandler The Pub 3 04-23-03 08:57 AM
ED XR6 front end???? 93XR6 General Tech 3 08-08-02 04:27 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome