Electrical Shortage - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-14-2007, 18:33   #1 (permalink)
Registered User
 
Join Date: Feb 2007
Location: FL
Posts: 1
Exclamation Electrical Shortage

I own an 02 Lincoln Blackwood and I'm having some annoying electrical problems. I broke the driver's side mirror and right after I broke it the interior lights would not shut off, even after the door was closed. You could parkt the truck and lock it and the interior lights still stayed on. It seems like since then stuff has been running all crazy. For starters, all the memory control stuff on the driver's side does not work. The mirror switch doesn't work, the foot pedals won't adjust, the driver's seat will not slide forwards or backwards, but other things still work on the drivers side. Like the lumbar of the seat, the seat heater and cooler, window switches and locks work fine. I don't understand it. It keeps blowing out the number 4 fuse under the dash and I can't find the short anywhere. Another thing that happened, but it could be a fluke is I had amps mounted behind the rear seats in the factory panel that houses the factory sub woofer and rear window defogger wiring. Well on the way to work Saturday morning, one of the defogger lines in the rear window melted. It was very cold out side, in the mid 50's and the window got so hot it caused the window to crack. The back window blew up pretty much all the way around the trim on the driver's side. I can't tell if that's part of my electrical problem or not. None of the amp wiring is touching the wires that connect to the rear defogger. And just this past sunday I installed a Optima yellow top battery and now the back up sensors don't work. It's been doing this stuff off and on since I installed a stereo system in it. After installing the system the fuse for the brake switch for the tail lights popped. I want to get it fixed, but I know that the local Ford and Lincoln dealership is going to rip me a new one with the labor rates. My truck needs help. Any ideas?
dpkn03 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-22-2007, 20:21   #2 (permalink)
91 F 250
 
Join Date: Feb 2007
Posts: 13
Re: Electrical Shortage

start by looking for broken wires pulled wires ect inside the door
__________________
Where is the mud??? And yes its 2 wheel drive
cjbarron5 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:52.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.