electronic display problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-21-2002, 11:19   #1 (permalink)
mickt
Guest
 
Posts: n/a
electronic display problem

My display is very faint. I have tried to make it brighter by using the switch but it still doesn't get any brighter. Anyone know what could be causing it to stay dim?
  Reply With Quote
Sponsored Links
Advertisement
 
Old 04-21-2002, 14:19   #2 (permalink)
The Goodz
Guest
 
Posts: n/a
Maybe the globes are burnt out? The globe isn't blown, it's burnt, the glass is like all black and dark... This happened in my trip computer, went very dim and then eventually blew. Try looking at the globes and replace them if necessary.

Alex
  Reply With Quote
Old 04-21-2002, 16:38   #3 (permalink)
mickt
Guest
 
Posts: n/a
Thanx Goodz, turned out to be just a fuse. I pulled it out and put it back in and it was a-ok.
  Reply With Quote
Old 05-03-2002, 21:56   #4 (permalink)
klomp
Guest
 
Posts: n/a
EB Ghia..LCD'S gone to lunch

Today I lost all lights to all LCD displays....for the life of me I cannot suss it out any ideas?
PS everything else is great just very hard to see speedo,trip meter,climate control,doors open map.....
  Reply With Quote
Old 05-04-2002, 08:06   #5 (permalink)
Brent79
Guest
 
Posts: n/a
Re: EB Ghia..LCD'S gone to lunch

When i installed my ghia dash, i found the factory back-lit globes to be very dull... so i rewired the speedo and car outline globes to the ign power feed via a resistor... display is heaps brighter than standard.. looks good and the extra heat hasnt effected the dash in anyway :)

Brent
  Reply With Quote
Old 05-07-2002, 15:48   #6 (permalink)
KLOMP
Guest
 
Posts: n/a
Re: EB Ghia..LCD'S gone to lunch

Hey MickT...which fuse?....I know all my fuses are Ok but perhaps the info will help.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 CV engine problem 95CV Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 9 04-22-2003 20:17
Ford Motor Company To Set Vehicle Debut And Product Display Records At Detroit Show RPO83 Ford Worldwide News 0 12-13-2002 05:51
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-2002 21:39
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-2002 18:37
Electronic km's display!! XtRmn8 Interior | Electrical | ECU 13 10-29-2001 14:16

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.