Few problems with my Ford Escort 1993 1.3L) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-21-06, 12:32 PM Thread Starter
Ford Escort 1.4 1993
 
Join Date: Jan 2006
Age: 26
Posts: 10
Thumbs up Few problems with my Ford Escort 1993 1.4L

Hey, I'v reclenly got my slef a ford escort from an uncal. Who's geroriosul Gave me my first car as in 16 - 17 in april and i'll be driving then.

Right There a few things wrong with the interior. The interior light fails to come on when you open the doors. But comes on when you slid the switch along. But it dosnt work when the doors are opened in any switch mode ect. I'v tryed them all.

There also the back Window heater dosnt work But the light come's on on the switch - Fuse?

There also the indactors come on but fail to flash - Either on or the hazerds.

I put this here because of the electrical side of things. Im not sure if it should be some where else.

Thanks for reading hope you can help.

Cheers.

Last edited by Joe1989; 01-21-06 at 01:39 PM. Reason: Title was wrong.
Joe1989 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-21-06, 12:50 PM
CaR bUfF pRoDiGy
 
radrider's Avatar
 
Join Date: Dec 2005
Location: North Carolina
Age: 26
Posts: 219
Re: Few problems with my Ford Escort 1993 1.3L)

ok first of all, welcome to FordForums, and now to fix the light problem...

Quote:
Originally Posted by Joe1989
The interior light fails to come on when you open the doors. But comes on when you slid the switch along. But it dosnt work when the doors are opened in any switch mode ect. I'v tryed them all.
in the door jam there should be a little button type switch. check it. if it is broken, replace it. and ur problem should be no more. it may also be a connection problem in the doorjam switch, so id replace it anyway. its only about $3 so id do it just incase. now make sure the light switch is on the "door" option. otherwise it wouldnt work anyway.

u can get the door jam switch at Autozone, or Advance Auto, or any parts place like those.

hope that helps

as far as the rear window heater is concerned, i think it would be a fuse. try that first, seeing as its a cheap and easy fix. if not, the heater unit may just be old, broken, or just not working. but try the new fuse first.

and with the indactors...im not quite sure what to say about those...i havent dealt with those before. lets see if anyone else can help you with that...


but i hope this helps u out, good luck, and post it when u fix the problems.

^^YES I MADE THIS ON MY OWN^^
if u want one with your car in it, let me know and get me a picture of your car and how you'd like it to look.also let me know if you want to see some of my other signatures that ive done.
radrider is offline  
post #3 of 8 (permalink) Old 01-21-06, 01:11 PM Thread Starter
Ford Escort 1.4 1993
 
Join Date: Jan 2006
Age: 26
Posts: 10
Re: Few problems with my Ford Escort 1993 1.4L

Thanks for the reply. I'll give all the above a try - Could it have happened the same on the 2 doors?

Baring in mide i didnt try the passaner side doors becasue its parked close to a fance. But i'll give the doors a try next time.

Thanks again!

Last edited by Joe1989; 01-21-06 at 01:39 PM. Reason: Title was wrong
Joe1989 is offline  
post #4 of 8 (permalink) Old 01-23-06, 03:49 PM
CaR bUfF pRoDiGy
 
radrider's Avatar
 
Join Date: Dec 2005
Location: North Carolina
Age: 26
Posts: 219
Re: Few problems with my Ford Escort 1993 1.3L)

hey no problem man, glad to help.

let me know if it didnt work, or u have any more problems.

^^YES I MADE THIS ON MY OWN^^
if u want one with your car in it, let me know and get me a picture of your car and how you'd like it to look.also let me know if you want to see some of my other signatures that ive done.
radrider is offline  
post #5 of 8 (permalink) Old 01-28-06, 10:23 AM Thread Starter
Ford Escort 1.4 1993
 
Join Date: Jan 2006
Age: 26
Posts: 10
Re: Few problems with my Ford Escort 1993 1.3L)

Indactors still not fixed. You right about the Interior light its just the door switch, I'll replace that at some point.

Forgot the try the fuse. I'll do that next week. Cheers!
Joe1989 is offline  
post #6 of 8 (permalink) Old 01-28-06, 04:55 PM
Registered User
 
Join Date: Nov 2004
Location: Perth
Posts: 184
Re: Few problems with my Ford Escort 1993 1.3L)

Your indicator problem sounds like the flasher relay is U/S.

AUIII XR6 Ute
66 Mustang convertible
AUIII XR8 Sedan
nassi is offline  
post #7 of 8 (permalink) Old 01-29-06, 05:01 AM Thread Starter
Ford Escort 1.4 1993
 
Join Date: Jan 2006
Age: 26
Posts: 10
Re: Few problems with my Ford Escort 1993 1.3L)

What does u/s mean ? Broke?

Also - Can you replace them and Where can i buy one in the uk ?
Joe1989 is offline  
post #8 of 8 (permalink) Old 02-02-06, 12:07 PM Thread Starter
Ford Escort 1.4 1993
 
Join Date: Jan 2006
Age: 26
Posts: 10
Re: Few problems with my Ford Escort 1993 1.3L)

Hey, Got a chance to work on my car today and guess what the indacator started to flash, I even where the tick tock noise.

Well, Then it went wrong again and decided to stop working, Any ideas?

Also God my radio fixed 2 Thankd for the help, And i know whats wrong with the interor light!

Thanks a again, Any one got any ideas about the indacators? Thanks!
Joe1989 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome