Fuel pump - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-13-04, 07:49 PM Thread Starter
Registered User
Join Date: Nov 2003
Posts: 3
Fuel pump

I have a 94 5.0 Mustang the car won't start and the fuel pump keeps running with ignition on. and it does have gas :)

Last edited by Nascarman88; 01-13-04 at 07:57 PM.
Nascarman88 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
No juice @ fuel Pump. 93' Probe GT MikeP General Tech 2 06-13-03 02:39 AM
XE Fuel pump probs Chris5ltr General Tech 0 05-04-03 08:35 AM
Fuel pump noisey - 1997 EL wagon FordPrefect General Tech 3 12-23-02 04:29 AM
Carb motor-EFI fuel pump uteman General Tech 14 10-18-02 05:26 PM
Ford Product-Led Transformation: 2003 RPO83 Trans | Driveline 0 07-22-02 07:48 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome