Fuse problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-17-2005, 20:02   #1 (permalink)
Registered User
 
Join Date: Apr 2005
Posts: 15
Fuse problems

My 94 GM has an electrical bug. #4 fries any fuse (went through three). I didnt do any readings with my multi-meter yet (too dark). What wire leads to the i/p fuse box in the kick panel (if that is the problem)? I look at the wiring diagrams and I understand the basics but not how to fix my problems. Any suggestions?
districtborn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-23-2005, 00:51   #2 (permalink)
Registered User
 
TruBlu351's Avatar
 
Join Date: Apr 2003
Location: Newcastle
Posts: 2,398
Re: Fuse problems

There is something in that circuit drawing too much current which is frying the fuses.

Most likey short of some kind.

What is #4. ie: what does that circuit provide power to and what size fuse are you using?

Some smaller multimeters only have a 200 milliamp limit on them. If you're blowing fuses your current draw will probably be 10 to 20+ amps and you'll blow the fuse in the multimeter unless it has a bigger setting.

Its just a matter of following all the wiring related to that circuit and looking for problems........ranging from a broken wire earthing on the car body/chassis to some broken equipment that has an internal short.
__________________
XE Falcon
393 Tremec TKO 9"
TruBlu351 is offline   Reply With Quote
Old 08-14-2005, 22:19   #3 (permalink)
Registered User
 
Boost1105's Avatar
 
Join Date: Jul 2005
Location: melb
Posts: 3
Re: Fuse problems

I had The same problem with my EB Falc, it kept on burning fuses on my fan and blows when the fan is turned to 3

I was fed up so i sold the car to some unlucky guy
Boost1105 is offline   Reply With Quote
Old 08-14-2005, 22:34   #4 (permalink)
XW GT
 
DANGERXY's Avatar
 
Join Date: Jul 2005
Location: perth
Age: 29
Posts: 318
Re: Fuse problems

Do You Remember Which Fuse Blew When The Fan Turns On
__________________
'70 XW GT 351c 4V (SA)
'70 XW SEDAN
'71 XY FALCON UTE WORKED 351
'77 XC FALCON 500.
'92 EB FAIRMONT
'91 EB FALCON
'76 XB CONTINENTIAL
YES I LIKE MY FORDS TO
DANGERXY is offline   Reply With Quote
Old 08-14-2005, 22:52   #5 (permalink)
Registered User
 
Boost1105's Avatar
 
Join Date: Jul 2005
Location: melb
Posts: 3
Re: Fuse problems

Nothing else went dead so i'm assuming it was just the fan, one time it melted when i had it going full blast
Boost1105 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:49.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.