hello - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-04-03, 03:01 AM Thread Starter
Registered User
 
slothman's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 131
hello

My in side of my wagon has had that hot day old car smell , which is quite relaxing cose iam sad person ,, but today out of the blue this avo its stinks of old battery acid ,, for sure iam crook in the guts most days but this unreal,,

could the exhaust be burnt out around the catalic thingo and seapping in ,,,

ill just have to get it cleaned out and go from there,

thank you any ideas or thoughts..
slothman is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-04-03, 03:20 AM
Ford Appreciation Society
 
EBXR's Avatar
 
Join Date: Jul 2002
Location: ACT and loving it!
Age: 43
Posts: 3,666
Re: hello

How new is the wagon?

'67 Mustang V8 4sp... what fun to drive!
EBXR is offline  
post #3 of 5 (permalink) Old 09-04-03, 03:47 AM Thread Starter
Registered User
 
slothman's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 131
Are yes ,, its 9/88 is when it was made is that new enough.

yer its a shitter. ,, and Iam proud of it. its just never smelt like this,, thoug

gezz its rough..
slothman is offline  
post #4 of 5 (permalink) Old 09-06-03, 01:40 PM
Registered User
 
Join Date: Sep 2002
Location: 27 00S 153 07E
Posts: 1,944
Re: hello

If it stinks of old battery acid, fair chance the smell is coming from the battery. If your alternator regulator goes kaput, you can "boil" the battery and the gas smell seeps into the cabin. Been there, done that. First step is check the water levels in the battery, if low, that could be a possible cause.

Oh, and cheer up, it may never happen. Go outside and light up a big fattie.

"I married Miss Right. I just didn't know her first name was Always."
TopGhia is offline  
post #5 of 5 (permalink) Old 09-06-03, 10:34 PM Thread Starter
Registered User
 
slothman's Avatar
 
Join Date: Jun 2003
Location: Australia
Posts: 131
hey

Well matey ,, what you say makes sense , i guess ,, went and checked the battery and well i do not know whats high and whats low,, put it this way i could see the battey liquid and no eleaments were exposde.

Ive just had the radaitor replaced and fan and belts and stuff changed etc ,,, so its not cooling its eletrical cooling is that right.

i thinks ive phucked up on the gamble and its about to all go , bang.
slothman is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome