HELP! Odometer and trip meter issues - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-18-2004, 03:03   #1 (permalink)
Mad Redhead
 
Join Date: Jul 2004
Location: Blue Mountains NSW
Age: 42
Posts: 113
HELP! Odometer and trip meter issues

Hi all,

Well I thought my EA probs were all over, until yesterday. A couple of days ago hubby asked me how many k's we'd done and I said 348. So we decided we'd better fill up soon.

WELL, yesterday I was at the petrol station (using my patented spark plug jammed in the filler - I always stand right next to it, just stops my hand from aching!) and all was fine. I went to centre the trip meter again when I noticed it said 348k's. I thought to myself, that's strange, isn't that the amount I told hubby we were at the other day? Thought I was losing my marbles and centred it to 000.

Drive away. 3 k's down the road I realise that the trip meter hasn't moved. Play with the bugger. Still does nothing. I figure, great, the thing's dead. I'll just go by the odometer. It's on 208211. Fill up at 208611. Get home (10 k's later) to find it is STILL reading 208211!!!

What the hell is this? The speedo has never been accurate but it's still working, all the other gauges are fine.

Any help appreciated!
__________________
Bindi

EA 88
Corolla 88
______________________________________________

The story of my life...
bindi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2004, 03:08   #2 (permalink)
No longer around
 
MADNC_8's Avatar
 
Join Date: Jun 2002
Location: Geelong
Age: 33
Posts: 4,882
Re: HELP! Odometer and trip meter issues

hmm both arent working?..... hmm, no expert, but it sounds more like a loose connection of something rather than a cluster stuffup.......... or do they both operate off each other?

dunno.......
MADNC_8 is offline   Reply With Quote
Old 10-18-2004, 03:13   #3 (permalink)
Mad Redhead
 
Join Date: Jul 2004
Location: Blue Mountains NSW
Age: 42
Posts: 113
Re: HELP! Odometer and trip meter issues

dammit,

I don't want to take the dash off, I did that in my XF a few years ago and never got the bastard back on quite the same. Always looked a little askew!

Is there an easy way to get to the cluster without taking the whole thing apart?
__________________
Bindi

EA 88
Corolla 88
______________________________________________

The story of my life...
bindi is offline   Reply With Quote
Old 10-18-2004, 03:28   #4 (permalink)
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
Re: HELP! Odometer and trip meter issues

The cluster is not hard to remove, you just have to remove the panel surrounding it from memory - 3 screws at the top? Worst case scenario could be a replacement cluster, which are ultra cheap secondhand.
__________________
Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline   Reply With Quote
Old 10-18-2004, 05:17   #5 (permalink)
FCT Blue eyed bucket (TM)
 
Cobalt_bucket's Avatar
 
Join Date: Jan 2004
Location: Brisbane, southside
Age: 32
Posts: 257
Re: HELP! Odometer and trip meter issues

bugger a new cluster the most common things with the cluster is the odometer gear breaks take the cluster to any good speedo place and they can repair it or send it to Automotive EMF in brisbane they do heaps of these ph: 3000 4000
Cobalt_bucket is offline   Reply With Quote
Old 10-18-2004, 13:47   #6 (permalink)
Mad Redhead
 
Join Date: Jul 2004
Location: Blue Mountains NSW
Age: 42
Posts: 113
Re: HELP! Odometer and trip meter issues

Well, if I were in Qld I suppose I could take it to this dude... but I'm not! Thanks Thanatos, I might check it out before I go anywhere... can't hurt to look.

I shall ring around and see who does this stuff. TA all!
__________________
Bindi

EA 88
Corolla 88
______________________________________________

The story of my life...
bindi is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odometer Not Working... j_biafra88 Interior | Electrical | ECU 18 10-31-2004 20:44
Odometer Stopped EA-XR6 Inline 6 Tech 16 09-05-2004 19:18
HELP: ED odometer not working!!! tickford5400i General Tech 5 05-19-2003 05:21

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:22.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.