Horn stopped working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-24-2007, 13:20   #1 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 4
Horn stopped working

I have a 2002 Ford F-150 Super Crew. I am sure this problem is probably something simple, but I wanted to check before I start pulling relays, fuses, etc. Last year, while duck hunting, my horn got full of mud. I got it all cleaned out, but since then the horn was sounding like a sick cow. It continued to do that until about a month ago, when it blew one last time, and no longer works. I had blamed it on the horn, but a friend of mine made the comment that it might be a bad connection. Anyone have any idea about what could have happened? I am about to start working on it, but thought I would check for any advice first. Appreciate it.
brody is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-24-2007, 14:59   #2 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 4
Re: Horn stopped working

Floow up on the problem......after reading through some of the posts, I checked my relay and switch. Whenever I push on the horn, I can hear clicking in the power distribution box. I pulled the fuse to check, and it looked okay. I unplugged the wiring from the horn itself, and using a test light, got nothing. I peeled the wires a little down from the plug, and nothing. But the wires go into a larger harness that leads to who knows where. Can anyone tell me where the wires terminate closer to the distribution box so I don't have to tear out all the wires and take a chance on electrocuting myself, or shutting down my truck completely???
brody is offline   Reply With Quote
Old 09-24-2007, 15:00   #3 (permalink)
Registered User
 
Join Date: Sep 2007
Posts: 4
Re: Horn stopped working

Meant follow up, not floow up!!!
brody is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:02.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.