Instrument cluster showing "THEFT!"and truck won't start ????? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-30-03, 05:44 PM
Posts: n/a
confused Instrument cluster showing "THEFT!"and truck won't start ?????

OK, here's the story and I hope someone can help. I have a 2002 Ford F150. My instrument cluster is broke "long story" anyway I went to the junk yard and found another one with close to the same mileage. When I installed it my "THEFT" light is flashing and the truck won't start. I took off the + and - battery terminals for 10 min. and rehooked them hoping to reset the "THEFT" light but its still flashing and the truck still won't start. Any ideas on what to do, how to reset it? I did put the old one back in so the truck will run for me until I get this figured out.
Sponsored Links
post #2 of 3 (permalink) Old 11-02-03, 02:43 PM
Lamahs approve of manuals
Join Date: Mar 2003
Location: Sydney, Australia
Age: 38
Posts: 1,382
Re: Instrument cluster showing "THEFT!"and truck won't start ?????

Damn ! Shouldn't it still be under warranty ?

Anyways, I'm thinking your quickest course will a call to the local dealer. Sounds like they have some sort of security implemented there, and I would expect they have put some effort into making it tricky to get round unofficially . . .
XR8 Lamah is offline  
post #3 of 3 (permalink) Old 11-02-03, 03:10 PM
89F150's Avatar
Join Date: May 2003
Location: Albury, NSW
Posts: 1,012
Re: Instrument cluster showing "THEFT!"and truck won't start ?????

I think you need to turn the lights on as well, so to get rid of any excess power but i am not to sure. Maybe someone in the Ford truck section can help you, if they dont get here first
89F150 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
XG to XF instrument cluster conversion? falconS General Tech 7 12-12-03 03:26 AM
I need a picture of an XF instrument cluster. help! falconS General Tech 15 01-12-03 07:33 PM
Monaro series 2 pics FPRXR-6 The Pub 28 12-10-02 09:43 PM
Instrument cluster Zomwit General Tech 8 03-12-02 06:54 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome