Instrument Panel W/Tach install problem. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-01-07, 03:36 PM Thread Starter
Registered User
Join Date: Mar 2007
Location: Spokane, WA
Posts: 1
Instrument Panel W/Tach install problem.

I have a 1983 F150 300 I6, Dual gas tanks, Manual 4spd. I found a dash/instrument panel with a stock Tachometer and verified with a Ford Parts Dept. that it was for 81-86 year models. But, my 83 has a 16 pin dash wiring harness and the panel with the tach has a 19 pin. I was then told the Tach was not an option in 1983.
Sooo, is the info I am getting so far correct? If so, what years would I look to for a 19 pin wiring harness and will there be problems using it in my 83?

Harte3 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome