lighting,blinker,hazard,brake, problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-16-04, 09:06 PM Thread Starter
Registered User
Join Date: Mar 2004
Posts: 2
frown lighting,blinker,hazard,brake, problem

hi there new here. hope im in the right place. here is my situation 97 crown vic. all of a sudden i lost rear brake lights exept third one in back window. lost all blinkers, lost hazards, the front blinkers barely work if i work the blinker switch manually. no clicking sound either. i have the haynes manual. and notice there is no blinker relay thing like the old days. it has a solid state lighting control module. maybe this is the problem. i checked the fuses and tested the rear blinker bulbs for continuety. and the check out. i can fix alot of things but electrics are not my strong point. any help will be greatly appreciated. thanks hardknocks
hardknocks1 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 03-17-04, 08:06 PM
Can't wait for Winton...
outback_ute's Avatar
Join Date: Jul 2003
Location: Victoria
Posts: 2,759
Re: lighting,blinker,hazard,brake, problem

If they've all gone out together at once, it's most likely a common component.
outback_ute is offline  
post #3 of 3 (permalink) Old 03-21-04, 01:00 PM Thread Starter
Registered User
Join Date: Mar 2004
Posts: 2
Re: lighting,blinker,hazard,brake, problem

hi there i figured out what was causing the problem. i suspected the lighting control module, but that was not the case. it was the multi function switch. and now it works.
hardknocks1 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone had this gearbox problem??? XR6HP01 Trans | Driveline 16 08-31-03 08:32 PM
95 CV engine problem 95CV Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 9 04-22-03 09:17 PM
Ford said to fix Expedition problem RPO83 Ford Worldwide News 0 07-09-02 09:59 PM
Defective GM engines $30+ Bilion problem. Discovery The Pub 11 03-21-02 07:37 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome