Low beam not working on xf - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-28-03, 03:26 PM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Low beam not working on xf

Has anyone had this same problem before? I dont have a multimeter so cant check it out where the problem is easily.

My right sidelight has not low beam but parker. The left side is fine. I replaced the bulb and checked all wires around it and they SEEM fine. Highbeam on the same light WORKS.

Any help would be great.

Pete

fordmuscle_83 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-28-03, 08:14 PM
Registered User
 
Join Date: Sep 2002
Location: Melbourne , Vic
Posts: 202
Re: Low beam not working on xf

I'm 90% i had something like this happen, and it turned out to be an earth. There's a couple of earth (black) wires that go into a round eyelet crimp terminal that screws to the chasis above the headlight.

Hope that helps.
st00pid is offline  
post #3 of 8 (permalink) Old 12-30-03, 12:18 AM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Re: Low beam not working on xf

I never checked that! Im stOOpid. lol. It would make sense because it did work, then didnt, then did, now doesnt. Checking it now for earth.................
fordmuscle_83 is offline  
post #4 of 8 (permalink) Old 01-03-04, 11:00 PM
Registered User
 
Join Date: May 2003
Location: s.e brisbane
Posts: 128
Re: Low beam not working on xf

I had this problem too..

The relay box next to the battery should have 2 or 3 relays.

The relay closest to the windscreen operates low beams, then the next ones away does high beams, then the next one for fog lights if you have them.
X.treme.F.ury is offline  
post #5 of 8 (permalink) Old 01-26-04, 02:16 AM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Re: Low beam not working on xf

The light started working for a few days and now isnt again. Earth is all good and i played around with swaping the rely boxes and it still doesnt work............so im still not sure what the prob is :(
fordmuscle_83 is offline  
post #6 of 8 (permalink) Old 01-26-04, 03:48 AM
mmm..Vee 8
 
Join Date: Jul 2002
Age: 32
Posts: 496
Re: Low beam not working on xf

What about the switch itself on the instrument cluster surround...have you tried replacing that or cleaning the contacts?

Extreme

First Ever Car - '84 XF Fairmont Ghia....Big Luxo Tank, Just Gotta Love that Velour!
Previous Ride- '87 XF S Pak...Now Retired with 305,000 on the clock!
Previous Ride-'99 AU Falcon S,Got sick of the 6...Need a V8!

5/1994 ED Futura Classic 5.0 in Polyneisan Green - One of the last ever built
Extreme_2020 is offline  
post #7 of 8 (permalink) Old 01-26-04, 03:19 PM
BA'o'Matic 100% working.
 
Dellboy999's Avatar
 
Join Date: May 2003
Location: Victoria
Age: 45
Posts: 3,838
Re: Low beam not working on xf

Can you jump power through the relay and get them to come on, also swap the fuse with another working one, fuses sometimes need to be reseated or changed.

I did put something here, but it vanshied, I think

"So long and thanks for all the fish!"
Dellboy999 is offline  
post #8 of 8 (permalink) Old 01-26-04, 03:26 PM Thread Starter
Ford Member
 
Join Date: Jul 2003
Location: Robina
Age: 33
Posts: 364
Re: Low beam not working on xf

The weird thing about it is it never turns off and on while driving. Only on for a few days, and off for a week or two then back on.

I will try what everyones posted.

Thanks
Pete
fordmuscle_83 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to build a v8 XF (the proper way in my opinion) Ford Grunt General Tech 98 09-11-04 07:15 PM
XG to XF instrument cluster conversion? falconS General Tech 7 12-12-03 02:26 AM
High beam problem AndrewM General Tech 10 01-27-03 02:27 PM
Headlights - low beam not working two face Interior | Electrical | ECU 6 08-20-02 06:14 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome