Mass airflow sensor problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-14-2003, 09:08   #1 (permalink)
Registered User
 
Join Date: Jul 2003
Posts: 9
Mass airflow sensor problem

I drive a 95 T-Bird w/4.6L and have been having a problem for the last month or so with the Check Engine light coming on. The stored codes are 171 & 174 -- fuel trim system lean condition for both banks. I thought perhaps the injectors were dirty and ran a couple bottles of cleaner through the fuel system, but to no avail. I finally succumbed and took my car to the dealer, where they diagnosed a faulty mass airflow sensor with a $500 estimate to fix. Since they didn't have one in stock, I'm now researching my options to repair this problem to see if there's a more reasonable alternate to biting the bullet. Any suggestions out there? Thanks in advance for your help.
rjmac61 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-14-2003, 10:39   #2 (permalink)
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,561
Re: Mass airflow sensor problem

The oxygen sensor on the right side is going out or is dead.

I would replace your O2 sensor first. On average they run 40 - 90 depending on the brand used.
LunaticSVT is offline   Reply With Quote
Old 07-14-2003, 10:41   #3 (permalink)
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,561
Re: Mass airflow sensor problem

EEC IV Diagnostic Codes for Thunderbird & Cougar 1989-1997

Code 171: Oxygen sensor unable to switch, right side

Code 174: Oxygen sensor switching slow, right side

Just so you know.
LunaticSVT is offline   Reply With Quote
Old 07-14-2003, 17:15   #4 (permalink)
Shh i'm huntin more power
 
Jase_ELXR8's Avatar
 
Join Date: Jul 2001
Location: Melbourne
Posts: 1,764
Re: Mass airflow sensor problem

Those codes (as lunatic has stated) are to do with the oxy sensor on the right bank. If it was your MAF you should see the condition on both banks. How many K's has the car done??? Keeping in mind that oxy sensors are only good for 80,000Kms then they start to deteriorate. I would change all oxy sensors and clean hotwire on the MAF and you should be running as good as new...
Jase_ELXR8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


« auto stick | cruise »

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What Mass Air Meter should I get? B-1B Windsor Tech 14 07-19-2003 01:25
XE EFI Airflow Meter XESpakman General Tech 5 03-12-2003 00:20
EFI V8 Question - Grantenelli or Vortech MASS AIR????? XF 5.0 S General Tech 3 02-21-2003 23:08
Mass Air Flow Meter Improvments XR8XTC General Tech 10 08-14-2002 06:55

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:24.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.