My Ea S Falcon,fan speed 123 not working also my odometer not right,plz help. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-13-04, 12:13 AM Thread Starter
Registered User
 
Join Date: Sep 2004
Posts: 1
My Ea S Falcon,fan speed 123 not working also my odometer not right,plz help.

Hi gang,

Just found this site and it looks great.
Just would like some advice on what you think is the reason and how can it be fixed and roughly what price......

1.. My Fan speed,speed 1,2,3 not working, fan speed 4 works though.(for hot and cold air)

2.. My Odometer and Tripmeter moves along but moves way to slow it is not moving correctly.

Thx for all your advice in advance,is this a electrition job? to fix my above probs?

Thanks.
My Car is a Ea Falcon S 1990 30th anniversary model.
kinisme is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-13-04, 01:54 AM
Formerly EAII_Fairmont
 
AUII_Forte's Avatar
 
Join Date: Aug 2002
Location: Dubbo NSW
Age: 31
Posts: 917
Re: My Ea S Falcon,fan speed 123 not working also my odometer not right,plz help.

You need a new fan speed resistor. It screws into the blower cowling behind the glove box. You should be able to pick one up from the wreckers pretty cheap.

As for your other problem, I have no idea.

1992 AXII Telstar TX5 Ghia

121kW 2.5L DOHC V6 in a car that weighs 1100kg's and looks like a 4 banger from the outside......SLEEPER!

1988 EA S Pak 3spd CFI.....Soon to be a 250rwkw HSV eating machine.
Latest update......MPFI!!
AUII_Forte is offline  
post #3 of 3 (permalink) Old 09-13-04, 03:42 AM
mmm..Vee 8
 
Join Date: Jul 2002
Age: 32
Posts: 496
Re: My Ea S Falcon,fan speed 123 not working also my odometer not right,plz help.

With the odometer and trip meter it may be the nylon cog that makes them turn..might be starting to breakdown/loose teeth and that may cause it to revolve slowly...you have to crack open the instrument cluster to change it...

Extreme

First Ever Car - '84 XF Fairmont Ghia....Big Luxo Tank, Just Gotta Love that Velour!
Previous Ride- '87 XF S Pak...Now Retired with 305,000 on the clock!
Previous Ride-'99 AU Falcon S,Got sick of the 6...Need a V8!

5/1994 ED Futura Classic 5.0 in Polyneisan Green - One of the last ever built
Extreme_2020 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP: ED odometer not working!!! tickford5400i General Tech 5 05-19-03 06:21 AM
EA GHIA dash not working Falcon kid Interior | Electrical | ECU 6 02-14-03 07:13 AM
Latest istalment in EA S's journey into evils of speed EA S The Pub 31 11-24-01 02:07 AM
More speed crap from officialdom (& EA S) EA S The Pub 17 11-21-01 07:00 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome