pathetic girl in need of help! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-27-06, 12:12 PM Thread Starter
I know nothing...
 
Join Date: Jan 2006
Location: Glasgow
Posts: 4
pathetic girl in need of help!

Hi there,

I've no idea about cars at all, but I wonder if anyone could help me please?

I put my car into the gargae to get a new clutch put on it - the mechanic then phoned me and told me I also needed a "gear selector rod mechanism" as well. that was all fine so I went and collected my car today - since I've got it back I have a speedo that doesn't work and my engine warning light has came on.
When I called them they said it would be fine and to bring it in tomorrow - they also said the engine warning light was for the alternator

So my question is - has anyone ever came across this before, and would you say they were trust worthy enough to give my car back too, to fix?

Its a 2001 Y reg Ford KA classic, 1.3 manual.

Many thank yous to anyone who can shed some light on this for me,

cheers
hx

heather is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-27-06, 01:10 PM
Registered User
 
tufLTD's Avatar
 
Join Date: Apr 2005
Location: Caloundra, Queensland
Age: 53
Posts: 240
Re: pathetic girl in need of help!

If your speedo isn't working, that will cause the engine light to come on. Most speedo's have a speed sensor in them for the EFI computer & if it's not connected it will trigger a fault code & the light will come on. Maybe they haven't connected the speedo after the clutch job.
tufLTD is offline  
post #3 of 7 (permalink) Old 01-27-06, 01:50 PM
CaR bUfF pRoDiGy
 
radrider's Avatar
 
Join Date: Dec 2005
Location: North Carolina
Age: 27
Posts: 219
Re: pathetic girl in need of help!

Quote:
Originally Posted by tufLTD
Maybe they haven't connected the speedo after the clutch job.

agreed, good thinkin.

^^YES I MADE THIS ON MY OWN^^
if u want one with your car in it, let me know and get me a picture of your car and how you'd like it to look.also let me know if you want to see some of my other signatures that ive done.
radrider is offline  
post #4 of 7 (permalink) Old 01-27-06, 01:54 PM Thread Starter
I know nothing...
 
Join Date: Jan 2006
Location: Glasgow
Posts: 4
Re: pathetic girl in need of help!

Nice one, thank you very much. I'll give it too them tomorrow and hopefully it should be sorted.

Again, thanks hx
heather is offline  
post #5 of 7 (permalink) Old 01-28-06, 09:54 AM Thread Starter
I know nothing...
 
Join Date: Jan 2006
Location: Glasgow
Posts: 4
Re: pathetic girl in need of help!

Just back from the garage - it turns out they have broken the speed sensor and some sort of cable - which is why the lights and stuff were going on.
I'm really angry though even though they admitted it was their fault and they broke it, they won't give me a courtesy car and I won't get my own car back until wed/thurs.
heather is offline  
post #6 of 7 (permalink) Old 01-28-06, 02:29 PM
Registered User
 
tufLTD's Avatar
 
Join Date: Apr 2005
Location: Caloundra, Queensland
Age: 53
Posts: 240
Re: pathetic girl in need of help!

Why so long to fix it?
Oh well, at least they're fixing their stuff-up for free.
tufLTD is offline  
post #7 of 7 (permalink) Old 01-28-06, 09:09 PM
old B - new B
 
351cid's Avatar
 
Join Date: Jul 2005
Location: sunshine coast QLD
Age: 51
Posts: 890
Re: pathetic girl in need of help!

Quote:
Originally Posted by heather
Just back from the garage - it turns out they have broken the speed sensor and some sort of cable - which is why the lights and stuff were going on.
I'm really angry though even though they admitted it was their fault and they broke it, they won't give me a courtesy car and I won't get my own car back until wed/thurs.
thats a bugger......
always makes it tuff when your without a car but sounds like they were honest enough to admit that they had broken it , ( a lot of shops would proberly try and blame it on worn parts ).

working on cars myself i realise how easy it is sometimes for a part to get damaged when your working on it , (especialy when the car is getting a bit older) .

dave
`75 XB FAIRMONT SEDAN injected 351, toplaoder, disc brake 9", factory paint+ vinyl roof.
`03 BA XLS ute - lpg, auto, lsd, acid rush paint,
WWW.sunshield.biz
351cid is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome