Probs with XF charging system - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-18-2004, 15:09   #1 (permalink)
Registered User
 
Join Date: Apr 2004
Posts: 14
Probs with XF charging system

Howdy all
Ive got an 85 XF that the charging system is playing up on.
I changed the regulator yesterday and it now "seems" to be ok.
Measured at the terminals I get 13.9V at neutral idle with no load. 13.6V with high beam, heater and stereo.
Volt meter reads between 2 and 3 bars while driving which is slightly low but better than the overcharging I was getting with the old reg.
My question is.
a) What is the OEM electrical load on the XF?
b) What slot in higher output replacement alternators are available (60A motorcraft in at the mo)?

The only extra drain should be the 90/100W headlights instead of 55/60W and the 200W stereo (head unit only) which would take 100W on average at a guess.

Cheers
JB
spook is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
XF ghia interior into plain XF DansEdgli Interior | Electrical | ECU 27 01-23-2010 07:42
2000 Navigator nav system Captain Over Ford Expedition Forum | Lincoln Navigator Forum 1 03-16-2004 09:54
XF ghia dash speedo wont work in XF Falcon rodzxf Interior | Electrical | ECU 13 11-05-2003 03:20
Holdens new V6 EED-250 The Pub 52 08-09-2003 22:07

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:28.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.