Speedomter, Odometer quit working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2006, 16:29   #1 (permalink)
Registered User
 
Join Date: Jan 2006
Location: Canada
Posts: 2
Speedomter, Odometer quit working

Hello All,
Really need some advice and help. I have 1995 Ford Aerostar, just over 92,000 miles. About a month ago I changed the battery. I still need to tighten the serpentine belt but that is another question for another time. ABout 2 weeks ago I got into the van and started heading home from the Mall and noticed the speedo and odo were not working. Checked fuses etc when I got home. All are fine.

Did a ton of searching online and all indications lead to a failed speed sensor in the differential. Got the part replaced it and it still does not work. I checked the voltage at the connector to the speed sensor and its 4.9 volts. This seems rather low to me.

Can anyone tell me what else I should look at before I spend the big bucks to bring it to the dealer. I have a code reader that I just bought today and need to read up on it before I use it.

Any help would be greatly appreciated.

Putts
Putts255 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 22:30.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.