Warning Light - Coolant ('98 AU Ghia) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-12-2005, 07:21   #1 (permalink)
1998 AU Fairmont Ghia
 
Join Date: Jan 2005
Posts: 4
Warning Light - Coolant ('98 AU Ghia)

Evening all,
I have heard of this problem on Series 1 AU's however I have yet to come accross a solution.

Every time I drive the car the red coolant light is staying on, I have heard something about a faulty sensor somewhere. Could someone advise what and where I would look for this in the engine compartment and also if it can be fixed without taking it back to a Ford dealership.

Cheers

Readie
Readie is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-12-2005, 07:37   #2 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,880
Re: Warning Light - Coolant ('98 AU Ghia)

It screws into the base of the thermostat housing. But do yourself a favour and at least buy a cheap workshop manual (Haynes, Gregory's or Max Ellery) that will show you where it is.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 06-12-2005, 07:59   #3 (permalink)
Registered User
 
Join Date: Oct 2004
Age: 34
Posts: 159
Re: Warning Light - Coolant ('98 AU Ghia)

im prettysure its the sensor off the radiator bottle,check water sensor or somethin like that,happened to my car
u will easily see it ,it has wires coming off it and its an easy fix.
NC 5ltr is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 13:53.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.