Windscreen washers don't work - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 08-17-07, 04:43 AM Thread Starter
avg
Registered User
 
Join Date: Apr 2007
Posts: 2
Question Windscreen washers don't work

The windscreen washers on my 2004 Focus have stopped working. I can't hear any sound from the motor. Any advice appreciated as to next steps? There doesn't seem to be a dedicated fuse for the washers so am I right to suspect the motor? How do I get to it as it's not visible from the top?

avg is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-17-07, 06:15 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: Windscreen washers don't work

I would check all fuses with a test light or volt meter before replacing the motor. Also check for power to the motor.
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Interior | Electrical | ECU


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome